0

After selecting a shipping method and entering CC info I get this message (Shipping method has not been selected yet). This started happening out of the blue. Sometimes instead of getting that message I get a message asking for CC number again. Losing business. Please help.

1
  • Which checkout are you using? Check the log files located within /var/log of your Magento installation to check if something is going wrong.
    – Dave
    Aug 4, 2014 at 19:31

1 Answer 1

2

Welcome to Magento Stackexchange.

As it stands this question is not answerable by our community because it does not have enough information. There are literally innumerable things that could be wrong. I would guide you to check out the standard debugging guide to help you.


Helping anyway

That said, I did take a look at your site and I got the error specified:

enter image description here

I did, in fact, select a shipping method. Unfortunately after the selection step the progress bar indicated that it was then unset:

enter image description here

Guessing

If I had to guess I'd say a few places to tell your developer to look are:

  • Remove any modules rewriting the Onepage controller
  • Disable 3rd party shipment modules installed to test
  • Method is being 'unset' even after returning 200 OK from the AJAX post - so I'd look into observers intercepting the model save

I really can't give you any more information than that. This issue is just too broad and as I said this question is likely to be closed.

Best of luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.