0

I am updating my production site from 2.3.0 to 2.3.4. Updating goes smoothly with no errors at all. Yet my backend(adminhtml) is not updated!!

It still shows the old number (2.3.0) in the bottom right. Using php bin/magento -v on the cli I get the right version! 2.3.4

So I know that it seems to be on version 2.3.4, because the Export Products bug I was updating to fix is fixed! Also I was running ElasticSearch 5, and 2.3.4 isn't compatible so it stopped working. Yet when I go try to change the catalog search ElasticSearch 6 or 7 are not options!!

First I updated via composer. I'll list the commands, but I had no errors.

php bin/magento maintenance:enable
cp composer.json composer.json.bak
composer require magento/product-community-edition=2.3.4 --no-update
composer update
php bin/magento cache:clean
php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento setup:static-content:deploy -f
php bin/magento maintenance:enable

adminhtml seems to deploy just fine. I've tried clearing all caches. Applying the -area admin ti deploy. I also tried installing via FTP. I downloaded the full version of 2.3.4 and uploaded it and ran setup:update. No luck. I feel like I'm missing something really small. Thanks! enter image description here

enter image description here

Composer Version

0

I might be an issue for Magento. Flush all Magento cache Or

Check composer.json at Magento root directly. Might be composer.json still it version is 2.3.0. You need to changes that version manually to 2.3.4 or check JSON file at var folder's JSON files which are relater Magento corn.

| improve this answer | |
  • Checked 'composer.json' shows '2.3.4'. I have cleared every cache. Even deleting all files and running setup:static-content:deploy. Cache makes the most sense but I've checked everything. Really baffled on this one. – Darin Minard May 4 at 7:52
0

Quick update. Super simple solution. Deleted my Vendor folder and then reran composer update

I was pretty sure I already did this once, but hey it worked after.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.