2

I'm upgrading my Magento 2.3.2 to Magento 2.3.5 and I'm receiving this following error during upgrade:

Module ‘Magento_Wishlist’: Unable to apply data patch 
Magento\Wishlist\Setup\Patch\Data\CleanUpData for module Magento_Wishlist. Original exception 
message: Unable to unserialize value. Error: Syntax error

how could I solve it?

2

Probably happening because you have bundle products in your store.

Merchants who encounter this error after installing Magento 2.3.5 should upgrade to Magento 2.3.5-p1.

Merchants who encounter this error after installing Magento 2.3.4-p1 should upgrade to Magento 2.3.4-p2.

Reference: Wishlist error during upgrade to Magento versions 2.3.4-p1 or 2.3.5.

  • 1+ Right........... – Rk Rathod May 4 '20 at 10:36
  • @RkRathod I am facing this error while upgrading 2.3.4 to 2.3.5 so should i upgrade directly to 2.3.6 – Akshay Kamble Oct 27 '20 at 5:06
  • Yes, probably you will face the same error in 2.3.6 like some module upgrade needed, but then you will be in the latest version. – Rafael Corrêa Gomes Oct 27 '20 at 15:58
-1

Run these commands from the root directory of your store.

composer require magento/product-community-edition 2.3.5-p1 --no-update

composer update

php bin/magento setup:upgrade

php bin/magento cache:clean

php bin/magento setup:static-content:deploy -f

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.