3

I have tried every possible solution I could find on the internet.

From increasing the MEMLIMIT in the php.ini to 2G to removing the required tags in composer.json and so on.

This is a Vanilla install of CE 2.3.4 for the life of me I can not figure out what could be causing this.

I was actually trying to install the connector for Magento Store Manager and I figured it was an issue with the module but it does it with any extension.

1
  • What is the output when running composer update? – Hunter May 4 '20 at 16:48
2
+50

Did you already checked the Release Notes of 2.3.5? In the Known Issues section it is stating the following:

Issue: Magento 2.3.5 does not support upgrading using the Web Setup Wizard from deployments running Magento 2.3.3 or earlier without first manually updating dependencies for magento/updater. You can upgrade using the Web Setup Wizard without issue from Magento 2.3.4 to Magento 2.3.5. Workaround: Users should run the following commands before upgrading using the Web Setup Wizard:

cd update

&& composer update

5
  • I performed a vanilla installation of 2.3.5 and it still gives the error. Trying the composer update command. I will return with an update – Tommy May 1 '20 at 16:00
  • I did the composer update and now the site doesn't work at all – Tommy May 1 '20 at 18:21
  • 1
    @Tommy make sure you run all the follow up to the update, wipe all caches, bin/magento setup:upgrade etc – iphigenie May 1 '20 at 21:16
  • This is the part I am lost at. Either that or I have been looking at this way to long. Could you please list the commands? i.e. the follow up to the update? – Tommy May 3 '20 at 2:22
  • I ran these commands and I am still getting the dependency check error. This is a vanilla install, so could someone go in and check it for me? – Tommy May 3 '20 at 2:30
1

A bit of a stab in the dark but I have had strange issues in my installation until I started running composer starting with a call to a PHP executable and passing a memory limit.

In my case:

/usr/local/bin/ea-php72 -d memory_limit=3G  [full path to your composer executable]

Alas I haven't figured out how to edit the magento configs so the internal composer it calls now and then (eg: module:uninstall) also does the same so a few things still hang and need manual follow up

1

Did you check you PHP Version ? (php -v).

According to dev docs :

Supported PHP versions:

~7.2.0

~7.3.0

According to my experience, you should never use the last PHP version : the penultimate is always more stable than the last, so try PHP ~7.2.0.

0

I found the issue. Not sure it’s a fix, but I was finally able to figure out how to install modules via composer. I did it by accident, but inevitably it worked. Thank you for all the help everyone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.