0

I want to add 3rd party module from artifacts in my project. required all modules with composer but when I run composer update at the end I have following error

Fatal error: Uncaught LogicException: Module 'Infortis_Ultimo' from '/var/www/html/app/code/Infortis/Ultimo' has been already defined in '/var/www/html/vendor/Infortis/Ultimo'. in /var/www/html/vendor/magento/framework/Component/ComponentRegistrar.php:50
Stack trace:
#0 /var/www/html/app/code/Infortis/Ultimo/registration.php(6): Magento\Framework\Component\ComponentRegistrar::register('module', 'Infortis_Ultimo', '/var/www/html/a...')
#1 /var/www/html/app/etc/NonComposerComponentRegistration.php(29): require_once('/var/www/html/a...')
#2 [internal function]: Magento\NonComposerComponentRegistration\{closure}('/var/www/html/a...')
#3 /var/www/html/app/etc/NonComposerComponentRegistration.php(29): array_map(Object(Closure), Array)
#4 /var/www/html/app/etc/NonComposerComponentRegistration.php(33): Magento\NonComposerComponentRegistration\{closure}()
#5 /var/www/html/vendor/composer/autoload_real.php(70): require('/var/www/html/a...')
#6 /var/www/html/vendor/composer/autoload_real.php(60): composerRequire5d53fefe7010e16b8a45c in /var/www/html/vendor/magento/framework/Component/ComponentRegistrar.php on line 50
Script ([ $COMPOSER_DEV_MODE -eq 0 ] || vendor/bin/phpcs --config-set installed_paths ../../magento/magento-coding-standard/) handling the post-update-cmd event returned with error code 255

something is wrong with the script https://i.imgur.com/UxyFP2L.png how may I fix this ?

0

Maybe you can try this command:

composer install --no-scripts

Then run: composer update

Hope you help

Thanks...

1
  • I can't skip these scripts . its needed for pipelines Apr 23 '20 at 8:08
0

I think the issue is because you have the same module in 2 destination :

- app/code/Infortis/Ultimo
- vendor/Infortis/Ultimo

Keep the module either in app/code or in vendor .

2
  • I remove them everythime. It creates on both place by itself. Apr 23 '20 at 8:09
  • check if you have the extension in composer.json Apr 23 '20 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.