0

When I try install module via composer then I get issue from other extension which is already installed.

[user@s1 public_html]$ composer71 require new/modulemarketing


  [RuntimeException]
  Could not load package module/extensionname in https://repo.magento.com: [
  UnexpectedValueException] Could not parse version constraint 5.5.33 as ^5.2
  : Invalid version string "^5.2"



  [UnexpectedValueException]
  Could not parse version constraint 5.5.33 as ^5.2: Invalid version string "
  ^5.2"


require [--dev] [--prefer-source] [--prefer-dist] [--fixed] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [<packages>]...

Anyone have solution?

1
  • first composer update after check – Mohit Patel Apr 21 '20 at 18:33
0

Try to add your new/modulemarketing to your composer.json file and run the following command:

composer71 update new/modulemarketing

I hope that it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.