Place order issue in payment information in magento 2

enter image description here

Code was shared in github : https://github.com/sd2894/OrderAttribute

  • please enable developer mode and check with – Rakesh Donga Apr 21 at 15:36
  • Still i m get a same issue. Can you please give your github username i will my share code @RakeshDonga – divya sekar Apr 22 at 6:16
  • Any error in log ? – Hamendra Sunthwal Apr 23 at 16:01
  • I suggest you to debug the place order function. – Hamendra Sunthwal Apr 23 at 16:01
  • what other non core checkout related modules might you have installed, even if they are disabled? In my case an old version of the stripe module was one of the key problems – iphigenie Apr 23 at 16:44

It seems like you should have done some custom code on order creation event on your store. Or there might be any third party extension installed doing the same on your store.

This additional code is somewhere throwing an error that you can find in error logs under "/var/log" directory.

You can also turn on the error log by removing the comment from the line "ini_set('display_errors', 1);" in below located file:


This will show you the exact error in specific file along with line no. These steps should help you to resolve your issue.

You are feel free to ask any further queries.

Happy to help.


| improve this answer | |
  • Still i m get a same issue. Can you please give your github username i will my share code @Pratik Navapara – divya sekar Apr 22 at 6:15

try to check or debug in a custom module or third party module any set event after place order like

<event name="checkout_submit_all_after">
        <observer name="devi_checkout_submit_all_after" instance="Vendor\Module\Observer\NewOrder"/>

if set then disable event and hit below commands and then check order is placed or not

sudo rm -rf var/* generated/* pub/static/frontend/*
sudo php bin/magento setup:upgrade
sudo php bin/magento setup:di:compile
sudo php bin/magento setup:static-content:deploy -f
sudo php bin/magento ca:cl
sudo php bin/magento ca:fl
sudo chmod -R 777 /var/www/html/(project name)/

so you could find what is the exact issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.