1

I am facing an issue with Mirasvit SearchAutocomplete Module.

It's working properly with mysql search engine. And it stops working with the Elasticsearch6+ search engine.

Facing this error: Sorry, something went wrong. You can find out more in the error log in ajax response.

I have debug the code, it seems collection not working properly after activating the Elasticsearch search engine.

Have you guys faced such kind of issue?

2
  • Have you checked error log? Apr 21, 2020 at 13:12
  • Yes, I found the same error there. "Sorry, something went wrong. You can find out more in the error log"
    – Ravi Soni
    Apr 21, 2020 at 13:17

1 Answer 1

1

You need to assign Search Engine to Elasticsearch Engine which is compatible with ES 6. enter image description here

[Update]

Open vendor/mirasvit/module-search/src/Search/etc/di.xml and check the ES engine.

<type name="Magento\Search\Model\Adminhtml\System\Config\Source\Engine">
    <arguments>
        <argument name="engines" xsi:type="array">
            <item name="mysql" xsi:type="string">Magento Native MySQL Engine</item>
            <item name="elasticsearch" xsi:type="string">Magento Native Elasticsearch 2+</item>
            <item name="elasticsearch5" xsi:type="string">Magento Native Elasticsearch 5+</item>
            <item name="elasticsearch6" xsi:type="string">Magento Native Elasticsearch 6+</item>
        </argument>
    </arguments>
</type>

elasticsearch is for Mirasvit

5
  • Thank you so much @Sohel for the response but in my version 2.3.4 there are only 4 options. MySQL, Elasticsearch, Elasticsearch 5.0+, Elasticsearch 6.0+
    – Ravi Soni
    Apr 21, 2020 at 13:27
  • What is your magento version?
    – Sohel Rana
    Apr 21, 2020 at 13:32
  • It's Magento 2.3.4
    – Ravi Soni
    Apr 21, 2020 at 13:40
  • Something wrong with your installation then. Check updated answer.
    – Sohel Rana
    Apr 21, 2020 at 13:45
  • Thanks for your time. I have to debug more for this..
    – Ravi Soni
    Apr 21, 2020 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.