on our site, many image links seemed to be broken, when you clicked on the image it did not show or showed a broken link even in the product grids, but when you refreshed the browser after trying to click on it.. it shows fine, like it had to be woken up. The admin page always worked and shows the image in the product. To try to fix this we ran php -f bin/magento catalog:images:resize but while it is STILL running it has blown the inode count through the roof.. to well over 500,000 can counting. This puts us WAY past our limit and we can't afford to upgrade to a better hosting option.

What is the cause of this crazy inode count?
Can I reduce it in any way and still have the images show?

******* UPDATE The resize completed... created over 500k files in the /pub/media/catalog/product/cache directory We refreshed the caches and all images work fine on the site.
We blew out our inode limits ... we ran these steps:

  1. Run images:resize (took 6 hours)
  2. Click on Flush Catalog Images (deleted /pub/media/catalog/products/cache)
  3. Click on FlushMagento Cache
  4. Refresh browser for front end

I am back where I started, the images have broken links on front end.. back end is fine.

broken links

If I click on a broken link and go to the product page the picture still is not there.. if I go back to this page and refresh the product image will show again, as it has created a \cache file. So basically unless there is a file in the cache folder the image will not show.. I have tried 3 computers and 3 different browsers with same effect. The Siteground caches are all off...

I suspect that there could be an issue with the .htaccess file? is that possible?

-Ken -Ken

  • you run the all command and permission command ?? Apr 17, 2020 at 20:11
  • Yes cleaned permissions all looks good permission wise.. Apr 18, 2020 at 21:32

1 Answer 1


I'd like to explain to you that you had some mistakes with those steps. You ran step 1 to create the image caches then moved to step 2, you deleted all. Therefore, you found that there were no images!

To resolve this issue, you need to run again step 1 then finish it. Or run step 2 -> step 3 -> step 1.

Please leave a comment if it works!

  • You are not understanding the full issue. When I run step 1, it creates all of the cache files.. there are TOO MANY and exceed the inode limit. So I have to delete them.. (I know that is just creating then removing them) .. once I remove the cache image the main image should be used.. it is not being used.. even after a flush.. Apr 23, 2020 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.