I am using Devilbox and these specifications :


I have cloned the project and I have launched these commands

From phpmyadmin

insert into core_config_data (config_id, scope, scope_id, path, value) values (null, 'default', 0, 'dev/static/sign', 0);

and this one

bin/magento  setup:static-content:deploy -f && bin/magento s:static-content:deploy es_ES en_US de_DE fr_FR -f

from Devilbox Shell but nothing has worked , always I got Page containing HTML without CSS There is no CSS render and I got always this message in the console

Failed to load resource: the server responded with a status of 404 (Not Found)

That it is shown for CSS , JS and fonts resources. I have tried also to empty the cache and nothing works If anyone needs any other details you could ask me.

Thanks in advance

1 Answer 1


It may be related to the file permissions issue. Run these commands and check again.

chmod -R 777 var/;

chmod -R 777 pub/static/;

chmod -R 777 generated/;

  • I have used chmod -R 777 var/ Commented Apr 16, 2020 at 14:59
  • Set 777 for pub/static and generated directory too
    – Ahsan
    Commented Apr 16, 2020 at 15:01
  • ok I will check with that and I 'll inform you Commented Apr 16, 2020 at 15:09
  • Thanks but that changes nothing, what may I do after thoses lines concerning 'chmod' Commented Apr 16, 2020 at 15:53
  • Can you share the url of css ?
    – Ahsan
    Commented Apr 17, 2020 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.