0

in my system it show the last my setup version 2.3.4 my question is "it show the latest version with all or show your setup version and other degrade versions"

name : magento/product-community-edition descrip. : eCommerce Platform for Growth (Community Edition) keywords : versions : * 2.3.4, 2.3.3-p1, 2.3.3, 2.3.2-p2, 2.3.2, 2.3.1, 2.3.0, 2.2.11, 2.2.10, 2.2.9, 2.2.8, 2.2.7, 2.2.6, 2.2.5, 2.2.4, 2.2.3, 2.2.2, 2.2.1, 2.2.0, 2.2.0-rc30, 2.2.0-rc23, 2.2.0-rc22, 2.2.0-rc21, strong text2.2.0-rc20, 2.1.18, 2.1.17, 2.1.16, 2.1.15, 2.1.14, 2.1.13, 2.1.12, 2.1.11, 2.1.10, 2.1.9, 2.1.8, 2.1.7, 2.1.6, 2.1.5, 2.1.4, 2.1.3, 2.1.2, 2.1.1, 2.1.0, 2.1.0-rc3, 2.1.0-rc2, 2.1.0-rc1, 2.0.18, 2.0.17, 2.0.16, 2.0.15, 2.0.14, 2.0.13, 2.0.12, 2.0.11, 2.0.10, 2.0.9, 2.0.8, 2.0.7, 2.0.6, 2.0.5, 2.0.4, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 0.42.0-beta7 type : metapackage license : Open Software License 3.0 (OSL-3.0) (OSI approved) https://spdx.org/licenses/OSL-3.0.html#licenseText license : Academic Free License v3.0 (AFL-3.0) (OSI approved) https://spdx.org/licenses/AFL-3.0.html#licenseText source : []
dist : [zip] https://repo.magento.com/archives/magento/product-community-edition/magento-product-community-edition-2.3.4.0.zip names : magento/product-community-edition

requires magento/magento2-base 2.3.4 php ~7.1.3||~7.2.0||~7.3.0 ext-bcmath * ext-ctype * ext-curl *

Please help me to clear this query !!

4
0

First check the php version PHP 7.1 or 7.2

1- Run command :-

composer require magento/product-community-edition=your version --no-update

2- Run the composer update

composer update

And finally composer update command is done so run the below commands :-

rm -rf var/di/* var/generation/* var/cache/* var/log/* var/page_cache/* var/session/* var/view_preprocessed/* pub/static/* php bin/magento setup:upgrade php bin/magento setup:di:compile php bin/magento setup:static-content:deploy php bin/magento cache:clean php bin/magento cache:flush php bin/magento indexer:reindex

And my accpeted answer check please

Magento 2 - 2.1 to 2.3 update

2
0

Run these commands in root directory.

composer require magento/product-community-edition=2.3.5 --no-update

composer update

php bin/magento setup:upgrade

4
  • are you sure a Magento 2.3.5 version is released? Apr 19 '20 at 19:02
  • I run composer command and get error. Could not find package magento/product-community-edition in a version match ing 2.3.5 Apr 19 '20 at 19:05
  • Hello @KarunaKhatri not RELEASE magento 2.3.5 Apr 20 '20 at 5:31
  • @mohit devdocs.magento.com/release
    – ahsan
    Apr 20 '20 at 20:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.