0

I am editing the description of a certain product for hours now and saved alot during this time and it always worked and showed me the updated description in the frontend after reload, but now I suddenly get 404 site not found in the frontend.

So I tried php bin/magento indexer:reindex but it was not helpful.

I also flushed all caches.

I also tried to call the product directly with

https://www.example.com/catalog/product/view/id/3860

but I also get 404.

| improve this question | | | | |
  • Some products selected catalog,search?? – Mohit Patel Apr 16 at 9:07
  • "catalog, search" is selected in Visibility, yes. – Black Apr 16 at 9:10
  • You get 404 product error when URL are changed or not?? If yes, please check backend check URL are same or not.. – Mohit Patel Apr 16 at 9:15
  • I don't understand your question. Yes I get 404 error. – Black Apr 16 at 9:16
  • Without 404 products page URL and with 404 products page URL shar me please – Mohit Patel Apr 16 at 9:28
0

you always get 404 when system is unable to define the requested path which means system can't find the URL path

  1. check the path
  2. clean mangeto cache may be magento is loading from cache

    php bin/magento c:f

if this is not working then

  1. clean the browser cache as well

and for design deploy content

php bin/magento s:s:d -f en_US en_GB

hope this answer helps

| improve this answer | | | | |
  • Does not work too. I even tried to call the product directly by using it's ID, https://www.example.com/catalog/product/view/id/3860 but I also get 404. – Black Apr 16 at 9:18
0

I finally solved it. I compared each option of a not working product, with the options of a working product.

I figured out that there is a option "Product at websites" (Produkt auf Webseiten [german]).

There is a checkbox and it was not selected in the not working product, for some unknown reasons. No one has ever changed it as the log proofs, so it must have been changed by magento logic or by a bug.

After this I had to flush the "Page Cache" and now it works again.


I think because I enalbed "Single Store Mode" and disabled it again because my design was not loading anymore because of it. But I did the same in another shop and do not experience the same issue there...

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.