2

This seems like it should be easier than I'm finding it. How can I change the label of SKU on a product page (and well, everywhere I guess) to "Article Number"?

I changed the label in attributes, I've changes the translate csv, but still it always shows SKU... weird! I'm using Ultimo if it helps.

Thanks.

updates

in the view.phtml file I have this:

<?php if ($theme->getCfg('product_page/sku')): ?>
                <div class="sku"><span><?php echo $this->__('SKU'); ?>: </span><?php echo $_product->getSku(); ?></div>
            <?php endif; ?>

If I hard code SKU to Article Number, I of course break the translation which enables the German version (which works!).

In the back-end, I have the following labels set:

Admin  - English  - German
Article Number  - Article Number  - Artikelnummer   

If I goto \app\design\adminhtml\default\default\locale\en_US and the translate.csv

I have these entries:

SKU - SKU

So I changed them to SKU - Article Number, but still doesn't change in the frontend.

3
  • Have you changed it in admin and database for all stote views?
    – Amasty
    Aug 2, 2014 at 19:35
  • I think so... see my updates. Did I miss something?
    – egg
    Aug 3, 2014 at 6:41
  • Did you clear the translation cache?
    – benmarks
    Aug 3, 2014 at 14:08

4 Answers 4

2

Add the file Mage_Catalog.csv and translate it here.

Also, enable the template hints, find the real block name and the template. They can be rewritten by an extension. In this case add the extension translate as well.

2
  • adding to the Mage_Catalog.csv file was the only solution that worked from all suggested! Thanks :) Though, it does seem like the one from Simon should have also worked??
    – egg
    Aug 6, 2014 at 16:36
  • Glad to be of service. I have figured this case when support one of our modules. The module rewrites the block and none of the translations in this block worked. Reason was magento takes translation from current module. As there are several places where the same string is defined sometimes translation becomes tricky.
    – Amasty
    Aug 6, 2014 at 16:52
4

Try it with these entries in your locale/en_US/translate.csv:

"SKU","Article number"
"Mage_Catalog::SKU","Article number"
"Mage_Sales::SKU","Article number"

Probably only one of the latter two is needed - just try it.

1
  • wierd, didn't work - but Amasty's did.
    – egg
    Aug 6, 2014 at 16:37
2

It might be cached or hardcoded in your PHTML. Open app/design/frontend/[yourtheme]/[yourpackage]/template/catalog/product/view.phtml and see there how that label is implemented .

2
  • thanks - I've updated my main question with the results.
    – egg
    Aug 3, 2014 at 6:39
  • Did you removed the Cache? What happens If you turn on the translation from the developer tab? Does it show the translated value in the modal?
    – mbalparda
    Aug 3, 2014 at 7:45
2

The best solution to rename sku is

Steps:

  1. First go to attributes in beckend.
  2. select catalog->attiributes
  3. Find Sku attibute in list of attributes then Go to manage label/optiona .
  4. Change the title want you...
1
  • thanks - I've updated my main question with the results. This didn't work :(
    – egg
    Aug 3, 2014 at 6:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.