1

I wanted to try and install the Cybersource package on Magento. On the marketplace, I had the option to download the package. When I did the only thing in the download was this composer.json-

{
"name": "cybersource/global-payment-management",
"description": "CyberSource Global Payment Management",
"version": "3.1.5",
"type": "metapackage",
"require": {
    "cybersource/module-3dsecure": "3.1.5",
    "cybersource/module-account-updater": "3.1.1",
    "cybersource/module-address": "3.1.2",
    "cybersource/module-applepay": "3.1.0",
    "cybersource/module-atp": "3.1.0",
    "cybersource/module-bank-transfer": "3.1.0",
    "cybersource/module-core": "3.1.2",
    "cybersource/module-echeck": "3.1.1",
    "cybersource/module-klarna": "3.1.1",
    "cybersource/module-paypal": "3.1.1",
    "cybersource/module-secure-acceptance": "3.1.5",
    "cybersource/module-tax": "3.1.2",
    "cybersource/module-visa-checkout": "3.1.0"
},
"license": [
    "proprietary"
]
}

I tried to use the require cybersource/global-payment-management when I did this is the error I got-

[InvalidArgumentException]                                                   
  Could not find a matching version of package cybersource/global-payment-management. Check the package spelling, your version constraint and that the package is available in a stability which matches your minimum-stability (stable). 

I looked on packagist but didn't see the package. This is a really common product. How can I install this with the composer?

3 Answers 3

3

Running composer require cybersource/global-payment-management should work when executed from your Magento root folder. The following might prevent it:

  1. repo.magento.com was removed from the repositories section of your composer.json file
  2. The login credentials used to access repo.magento.com are different to the user that placed the order in the Marketplace see the documentation for generating access keys here
  3. Adobe has not yet placed the package into your repo.magento.com repository - you would need to follow up with Magento Marketplace support if this is the case
2
  • I just updated to 2.3.4 using composer last week with no issues so I don't think it is that. I also tried this morning and still nothing. Apr 16, 2020 at 13:53
  • I added to the wrong repo.magento account. So you were correct Apr 16, 2020 at 15:54
2

I have installed the module in 2.4 and found the same error. enter image description here

This is working now, Please find the below steps:

Go to the marketplace account https://marketplace.magento.com/customer/accessKeys/ and create an access key. Go to project path and create an auth.json file or copy auth.json.sample and rename it with auth.json. Please add your key like(I have mixed the text inside the key)

{
"http-basic": {
    "repo.magento.com": {
        "username": "2bb6569b77'mycode'772362e5ea22bb1",
        "password": "27c4e2eb'edited'378fa5f408a4516b"
    }
}

}

Then after that run the below command

composer require cybersource/global-payment-management

Now it's working fine. Hope this helps you!

Thanks

0

Cybersource Global Payment Management Extension for Magento 2 Composer Install


Install Cybersource using via Composer

  • aws ec2 Magento 2.3.2, ubuntu, nginx, php 7.2, mariadb,

Maksure Ram value more than 4GB before the composer install

free -h

Install extension via Composer

go to your magento 2 installation directory

cd /var/www/html/

get 'superuser' / 'root' user privileges

sudo su

Start installation

composer require cybersource/global-payment-management

Enable Module s

php bin/magento module:enable CyberSource_AccountUpdater
CyberSource_Address CyberSource_ApplePay CyberSource_Atp
CyberSource_BankTransfer CyberSource_Core CyberSource_ECheck
CyberSource_KlarnaFinancial CyberSource_PayPal
CyberSource_SecureAcceptance CyberSource_Tax CyberSource_VisaCheckout

Compile Deploy and Upgrade

php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento setup:static-content:deploy

Restart

sudo reboot

store > Configuration > Sales

enjoy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.