0

I have installed Elasticsearch and it's showing below message when I run this command curl -X GET 'http://localhost:9200'

{
  "name" : "a_KnAuZ",
  "cluster_name" : "elasticsearch",
  "cluster_uuid" : "S-RwARt0SZGKMjYHqIuu5g",
  "version" : {
    "number" : "6.1.1",
    "build_hash" : "bd92e7f",
    "build_date" : "2017-12-17T20:23:25.338Z",
    "build_snapshot" : false,
    "lucene_version" : "7.1.0",
    "minimum_wire_compatibility_version" : "5.6.0",
    "minimum_index_compatibility_version" : "5.0.0"
  },
  "tagline" : "You Know, for Search"
}

Also, it's showing https://prnt.sc/rz8hio connection success message but when I am running index management command then it's showing below error message for catalogsearch_fulltext

{"error":{"root_cause":[{"type":"invalid_alias_name_exception","reason":"Invalid alias name [magento2_product_1], an index exists with thesame name as the alias","index_uuid":"MPr9O_RGTDKbDx4j4c8whg","index":"magento2_product_1"}],"type":"invalid_alias_name_exception","reason":"Invalid alias name [magento2_product_1], an index exists with the same name as the alias","index_uuid":"MPr9O_RGTDKbDx4j4c8whg","index":"magento2_product_1"},"status":400} 

I am using Magento version 2.3.0 Version, how can we solve this issue?

1

Magento 2.3.0 Only supports ElasticSearch 5.x. You will need to updated to at-least 2.3.1. or use a lower version of ElasticSearch.

| improve this answer | |
0

You have installed ElasticSearch 6.1.1 " number": "6.1.1", based on the screenshot and You have configured ElasticSearch 5.0 + in Magento admin.

  1. Change the Search Engine value to ElasticSearch 6.0 +

  2. Change the ElasticSearch Index Prefix from magento2 to m2es6 or some other value.

  3. clear cache and run catalog search indexer command again

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.