0

I installed Magento 2.3 successfully on one server and then moved it to another server by copying the files to public_html and uploading the database. It didn't work at first so I had to do various CLI commands including composer install and composer update. Now it works and all looks good inside admin but when you try and access the domain the home page only loads if I include 'home' or index.php after the URL

e.g. www.mydomain/home or www.mydomain/index.php work, www.mydomain does not work.

This is the error (which is incorrect - I already did a composer install), how do I fix this, did I transfer the site the wrong way?

Autoload error

Vendor autoload is not found. Please run 'composer install' under the application root directory.
  • other move after you chnag core_config table ?? – Mohit Patel Apr 9 at 5:01
  • I have found that this issue was only related to the "http" (non secure) address, the site home page was loading correctly for "https" (secure) address. Just putting this information out there in case it helps anyone else because the "Autoload error" error message is really very misleading. If anyone knows why this wrong error message occurs please post. – Byron Stuart Apr 10 at 1:50
  • @MohitPatel I uploaded the database to the new server and then I made the necessary changes to core_config_table (Magento was on a sub domain on original server). – Byron Stuart Apr 10 at 1:55
  • The site in question was running 2.2.5 and I had tried an upgrade to 2.2.9 but I could not get it to work using the Web Setup Wizard or the CLI. As an alternative to the upgrade I installed a clean copy of 2.3.4 on a different server because it requires a higher version of PHP incompatible with 2.2.5. I imported all the content into 2.3.4 and then copied the files back to the server running 2.2.5 (in a different directory). Finally I switched the site to use 2.3.4, maybe the way I did it created a weird security issue. – Byron Stuart Apr 10 at 2:17
  • Please your question shortly ?? – Mohit Patel Apr 10 at 5:06
0

In my case the "Autoload error" was fixed by installing a new SSL certificate.

Once the SSL certificate was installed I found that I could not access admin because the certificate was causing "http" to redirect to "https". To fix this I had to change the settings "Use Secure URLs on Storefront" and "Use Secure URLs in Admin" to Yes.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.