0

I am struggling with an strange issue that when i enable the Use Flat Catalog Category from admin the front is starting giving the following error in chrome

No data received
Unable to load the webpage because the server sent no data.
Here are some suggestions:
Reload this webpage later.
Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data.

and in mozzila - > nothing is displaying :'(

Not getting this at all what is going on. Any body any idea about this please help.

9
  • Anything in logs/reports? Commented Apr 18, 2013 at 14:11
  • nope .. no error log is generating and no php error is getting raise i have enabled all error log and php errors.
    – Ravi Soni
    Commented Apr 18, 2013 at 14:13
  • are we talking about magento or webserver logs? Commented Apr 18, 2013 at 14:14
  • webserver and magento both logs contain nothing.. :'( i just checked both
    – Ravi Soni
    Commented Apr 18, 2013 at 14:15
  • are your magento loggs enabled? Commented Apr 18, 2013 at 14:17

1 Answer 1

1

I have found the solution to my problem it was block html cache that was set to disable i think it is necessary for flat to work. I have followed following steps to sort out the issue.

  1. Disable the catalog category flat from admin
  2. Enable the all cache types especially the block html cache
  3. Enable the catalog category flat from admin
  4. Re-index the catalog category flat and catalog category products (Re-index all if they necessary)
  5. And voila that solved my issue

Hope some one found this helpful.

3
  • 2
    None of the cache types are required for flat catalogue or category to work. Most likely the index.
    – philwinkle
    Commented Apr 20, 2013 at 21:16
  • Hmm actually even i was wondered when i saw this issue solved after enabling the cache because i have checked by just doing re-indexing several times.
    – Ravi Soni
    Commented Apr 20, 2013 at 22:32
  • Please mark this answer as solution. Commented May 9, 2013 at 7:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.