0

I'm working on Magento 2 website that somebody developed before me. The website has Ultimo Theme. I'm trying to remove a block with a slider on the top of the home page. In the Ultime guide that block is referenced as "preface" static block (it's located below the navbar and right above the page content).

The actual block has CSS class "slideshow-wrapper-additional", but in the Admin Page in Content -> Blocks there is no block with such name.

So, should I remove using the Admin Panel or the direct connection via ftp/ssh?

I have Magento 2.2.9 and Ultimo Theme 2.

3
  • It probably coming from module not block. Search with that classname and see where it's coming from
    – Nayem323
    Mar 27, 2020 at 4:58
  • you can remove block and add into default.xml magento.stackexchange.com/questions/80425/…
    – Msquare
    Mar 27, 2020 at 7:56
  • I figured it out. It was in the list of blocks. I just didn't pay attention. When I was searching for the classname inside the website folder I wasn't getting any result. My guess is that blocks are stored in the database.
    – in43sh
    Mar 27, 2020 at 22:47

2 Answers 2

0

According to the ultimo theme doc, two possibilities :

  1. in Stores > Configuration > Slideshow >General > Main Slideshow on Home Page you'ill find identifier of a static block

  2. Or go to CMS home page and check if you find something like this :

    {{block class="Infortis\UltraSlideshow\Block\Slideshow" template="slideshow.phtml" slides="sample_slideshow_1"}}
    

If one of these two possibilities doesn't solve your problem, good luck to find out how it was integrated (Maybe directly in xml, in another cms block, phtml,...). The advantage of Magento is it's extensible, we can do things in several ways, but being a good developer is another debate.

2
  • I don't have Slideshow in Stores -> Configuration.
    – in43sh
    Mar 27, 2020 at 22:47
  • The block was not part of the page content. It was part of the "preface" which is Magento default static block, so it was included in the page somewhere and I couldn't find it.
    – in43sh
    Mar 27, 2020 at 22:49
0

I was able to resolve it. I was not attentive enough and missed the block. I checked again for that block and was able to find it in my list of Blocks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.