1

I am having an issue with my company's test site's Elasticsearch. Every time I try to do a reindex, the Catalog Search has the following error:

Catalog Search indexer process unknown error:

{"error":{"root_cause":[{"type":"illegal_argument_exception","reason":"Enabling [_all] is disabled in 6.0. As a replacement, you can use [copy_to] on mapping fields to create your own catch all field."}],"type":"illegal_argument_exception","reason":"Enabling [_all] is disabled in 6.0. As a replacement, you can use [copy_to] on mapping fields to create your own catch all field."},"status":400}

And this error occurs when I have set the Catalog Search on my site's Magento Admin panel to either Elasticsearch or Elasticsearch 6.0+. Now, I tried many different ideas to solve the above error. For example, setting the {"index.blocks.read_only_allow_delete": false} (and this solved an earlier problem). So, any suggestions would be helpful?

Now, here is my Magento site setup:

PHP version: 7.2.27

Magento version: 2.3.4 community edition

OS: CentOS 7.7.1908

Elasticsearch: 6.8.7-1

Also, I recently performed an in-place upgrade where I created the test site from a base Magento 2.3.4. Then, added all of the modules I needed. Finally, I copied over a backup of my company's production database and ran the Magento upgrade and compile commands (e.g., "magento setup:upgrade" and "magento setup:di:compile"). And note the production database was based-on Magento 2.3.1.

Thanks in advance for your help.

Regards,

Alvaro

  • Elasticsearch version? – Sohel Rana Mar 23 at 16:48
  • Oh, sorry @SohelRana, good point. I will add that to my original post. – Alvaro Mar 23 at 17:35
  • can you pul list of your searchable attributes for catalog – Yasir Latif Mar 23 at 18:04
  • @YasirLatif, thanks for the idea, I will look into the searchable attributes. – Alvaro Mar 24 at 17:31
  • So, I looked int the Magento database, specifically the eav_attribute and catalog_eav_attribute tables. And there were valid entries/rows in there. So, as a test, I decided to create a custom product attribute to see if updated both of these tables through the Magento Admin panel. And this worked. In addition, when I ran the reindexing command as the root user instead of using sudo (liked I did previously), the reindexing now works without any issues. Strange. – Alvaro Apr 2 at 17:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.