1

I am trying to edit a simple static block in Magento 1.9.0.1.
The static block is the main page of the Ma-Cance theme.

When I try to add a <p class="img5"></p> to the static block, and add some content, then save it... it throws away the code I just added.

I have no clue why this is happening...

The webstore is on a local Xampp server.
I have cleared all Magento's general caches and all other cache options are turned off...

Does anyone know what is happening?

SIDE NOTE: I know how to code in the Wysiwyg editor by using the Show/Hide button

EDIT 1: Turning off the Wysiwyg editor seems to give me back my code, but why doesn't it save the code when it is turned on by default?

9
  • Make sure that you are adding html codes in html part of CMS. You most probably adding html content inside content section. In order to switch to html part, you can use Show| Hide Editor button Commented Jul 31, 2014 at 7:21
  • I know how the Wysiwyg editor works... the problem is it doesn't save anything.
    – GrayleBV
    Commented Jul 31, 2014 at 7:23
  • Turning off the Wysiwyg editor seems to give me back my code, but why doesn't it save the code when it is turned on by default?
    – GrayleBV
    Commented Jul 31, 2014 at 7:31
  • TinyMce will do some code cleanup with will probably remove unused elements, I know it validates the html and has a set to things to look for. Commented Jul 31, 2014 at 7:34
  • @GrayleBV : Sometime I noted that html elements without any content inside it will be erased | moved my editor before it saving the contents. So try add some conent inside that <p /> and then try again Commented Jul 31, 2014 at 7:39

2 Answers 2

1

For adding HTML, first click on :

Show/Hide Editor

to disable the tools of editor and then add you tags

This LINK have a discussion and may help you out.

5
  • Clicking on the Show/Hide Editor button a couple of times to disable the tools does not work. I know how the editor works... It is just not saving any added code changes.
    – GrayleBV
    Commented Jul 31, 2014 at 7:22
  • Try this link, I guess this can help you out: magentocommerce.com/boards%20/viewthread/268262 Commented Jul 31, 2014 at 12:43
  • thanks, this seems to be the solution. Now to figgure out how to edit it ;)
    – GrayleBV
    Commented Jul 31, 2014 at 14:04
  • Please verify and confirm if it worked Commented Jul 31, 2014 at 14:07
  • it seems to work when you configure the TinyMCE. However I haven't figured out how to configure the TinyMCE correctly to what we need. Thanks for the solution.
    – GrayleBV
    Commented Aug 1, 2014 at 6:34
1

You need to click on Show/Hide Editor Button

Then you need to add your code here, when the looks like below:

You need to click on "Show/Hide Editor" Button if your window looks like just below Then you need to add your code here, when the looks like below:

1
  • 1. Your second image doesn't work; 2. Read the above answer / all other comments AND the side note in the question description. Thank you!
    – GrayleBV
    Commented Jul 31, 2014 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.