0

After enabling captcha for the contact form the captcha is not shown on the form. If submitted an "Incorrect CAPTCHA" error is displayed. Tried in production and development modes. No Javascript errors in the console.

Preconditions

Magento 2.1.6

PHP 7.0.12

MYSQLl 15.1 10.0.27-MariaDB

Varnish 4.1.3

Redis 3.2.3

Steps to reproduce

Select stores->Configuration->Customers->Customer Configuration->Captch->Forms->Contact us and save

captcha

Refresh caches

Clear varnish cache

We check links: https://github.com/magento/magento2/issues/9635

Magento 2 CAPTCHA not showing when enabled

But I think that there is not completely understood how to solve this problem. Can anyone give an answer here?

  • Can you check PHP logo in your system? Is there any hint on that? – Suman-PHP4U Mar 19 at 11:48
  • Solution could be read/write access (fixing permissions) to var/* and pub/*. – Suman-PHP4U Mar 19 at 11:48
  • We have valid write permissions for the var and pub directories. – Sylvester Mar 19 at 11:49
  • What is your Magneto version ? is there any error or exception is there in php log/nginx/apache log file ? – Suman-PHP4U Mar 19 at 12:07
  • Magento ver. 2.2.5. Let me check – Sylvester Mar 19 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.