2

I have posted this to stackexchange.com as well, before noticing that in the details of the forums not accepting new questions

I have noticed the issue when the CSS appeared to be broken. Heres what I have done:

1.) view source and noticed that forward slash "/" isn't being inserted after the URL

<link rel="stylesheet" type="text/css" href="http://myfantasygifts.comjs/mt/extensions/jquery/plugins/flexslider/flexslider.css" />

2.) also have checked phpmyadmin to be sure nothing has changed in the core_config_data table

enter image description here

3.) cleared out the contents within var/cache as well as var/session

4.) Logged into admin panel and reindexed Catalog URL Rewrites, this was a pain considering every click I had to manually add the forward slash after the domain.

5.) Changed permissions back to what magento requires resetting_file_permissions

6.) Checked all .htaccess files for url rewrite issue

7.) Cleared browser cache and tried in Google Chrome and Safari

I know that this has been posted numerous times and have tried numerous solutions that none of which seem to work so far. Any additional help will be greatly appreciated! And final, a huge Thank You in advance :)

  • What are the values for your other unsecure urls? i.e. SELECT * FROM core_config_data WHERE path LIKE "web/unsecure%" – Jasuten Jul 31 '14 at 1:27
  • Make sure to check app/etc/local.xml to make sure you're going to the correct database. I've given myself a headache after migrating a site with something similar only to find I was pointing to the old pre-migration DB. – pspahn Jul 31 '14 at 3:28
2

There is base_js_url default: {{unsecure_base_url}}js/. Check your configuration on different scopes: store/website and global.

Sometimes I bump into this cache|directory permission:

See if you have /tmp/magento. Delete it. chmod [magento]/var/cache to 777 recursive and assign user and group of web server to this dir recursively. Delete recursively dir /tmp/magento/ and the contents of [magento]/var/cache/*. Try it again until Magento saves in var/cache and not in /tmp.

You can debug in: Mage_Page_Block_Html_Head and Mage_Core_Model_Design_Package (for skin dir).

Actually I believe I remember an extension that messes up like this. See if an extension rewrites Core/Html_Head block, function _prepareStaticAndSkinElements. That extension did a small change in this function but used the code from an older Magento version. I may be wrong about the name of the function but not the class.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.