3

I am using magento 2.3.3 and I have enabled default magento Payflow Pro with Express checkout payment method. I have configured all required paypal merchant account details in admin area within payment method settings.

Now, if I try to place order with Express checkout method then it works fine. However, when I try to place order with credit card method then first paypal authorization request fired successfully with 0 amount. But then nothing happens and loader keeps spinning. I have also enabled debug mode and check logs in all log files but nothing relevant error information found.

This is default magento and I believe that there is no problem with paypal merchant account details configured at admin side otherwise Express method won't work. I have also found this issue created by someone on github magento2 repo at https://github.com/magento/magento2/issues/4408. However, no one had provided any exact solution over there as well.

Does anybody faced this issue in any project? Please help me as I am trying to resolve it since last few days.

Thanks in advance!

0

I am facing the same issue and paypal or magento enterprise team is unable to provide any solution. If you find anything, please do share it as it is driving me crazy.

| improve this answer | |
  • Please only answer post here, and comment are added in comment section – Msquare Mar 21 at 4:08
0
+50

I had the same problem

The issue was fixed by Magento team. The fix was delivered into magento/magento2:2.4-develop branch(es). Related commit(s):

abdb45844fd3862a8a2f852fb34d35cc0e958829 8ed20d151301484271b03755006e203e80ef76eb 8211eb79022e2167dad38349c63bb9c36279e34d 6d6af36f4fb31dfe7f585061d34332ed0819fe1a 45b9e193ddd8a413cb041976de6f1d9da5f53d5f The fix will be available with the upcoming 2.4.0 release.

| improve this answer | |
  • can you please provide the link to github? – Tora Aug 3 at 4:57
0

After lot of googling, I have also got multiple findings which can be the solution and might help someone looking for the same issue. Here I am listing all those one by one:

1) You need to configure Return URL Method in your manager.paypal.com account: Service Settings -> Hosted Checkout Pages -> Set Up -> Payment Confirmation section.

2) Go to your manager.paypal.com,

i) Then go at "Home --> Service Summary --> Hosted Checkout Pages -->Set up" and set Cancel URL Method to POST;

ii) Return URL Method: POST;

iii) Enable Secure Token: Yes;

This will capture the real amount after authorize the amount 0, this action works immediately.

3) Go to "Paypal Manager --> Account Administration --> Transaction Settings" and set Allow reference transactions to Yes. This action will take effect in an hour.

Hope this might be useful to others.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.