1

I am going to install Magento using the composer. I ran this command,

composer create-project --repository-url=https://repo.magento.com/ magento/project-community-edition

There is showing me an error white installing the package. Please check below screenshot for further information.

enter image description here

Note: I have installed elastic search package on my server. But i don't think this error is related to the elasticsearch. Can you guys help me?

Thanks,

2
  • 1
    did you found any solution @sunny Commented Aug 6, 2020 at 8:19
  • 1
    Are you able to solve this ? Commented Oct 9, 2020 at 14:42

2 Answers 2

2

Please install it using composer your error may be solved by installing this

If you use Composer, you can install PHP_CodeSniffer system-wide with the following command:

composer global require "squizlabs/php_codesniffer=*"

Make sure you have the composer bin dir in your PATH. The default value is ~/.composer/vendor/bin/, but you can check the value that you need to use by running

composer global config bin-dir --absolute.

Or alternatively, include a dependency for squizlabs/php_codesniffer in your composer.json file. For example:

{
    "require-dev": {
        "squizlabs/php_codesniffer": "3.*"
    }
}
3
  • this is already mentioned in composer.json Commented Oct 9, 2020 at 14:44
  • [Symfony\Component\Console\Exception\RuntimeException] The "--absolute." option does not exist. Commented Feb 19, 2021 at 12:36
  • use --absolute command without fullstop at last.
    – Dolly
    Commented Aug 15, 2023 at 16:51
0

I have sometimes faced this issue and mostly they were related to php version.

Lets check the requirement of your magento version, your php version . Even php_codesniffer requirement ( if have )

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.