When I run the Setup Upgrade Command. Getting below error

Notice: Undefined index: column in /vendor/magento/framework/Setup/Declaration/Schema/Declaration/SchemaBuilder.php on line 196

2 Answers 2


I've often ran into various errors when upgrading from 2.3.3 to 2.3.4. I'd suggest removing the vendor folder and re-running a composer install.

Before deleting the vendor folder, take a backup first to be safe.

sudo tar -zcvf ~/ecocraftvendor.tar.gz vendor

(places the zip folder into your home directory)

Remove vendor folders

sudo rm vendor/* -rf

Re-install composer

sudo su
php7.2 /usr/bin/composer install

Re-compile site

sudo php7.2 bin/magento setup:upgrade
sudo php7.2 bin/magento setup:di:compile

Flush cache/sort permissions etc.


This article helped me out a bunch:

print_r($table) in the SchemaBuilder.php on line 196

Then run the command,

bin/magento setup:upgrade

You will find the table name which causing the issue.

  1. First check that table and column is present in DB or not.
  2. Second, check the module is disabled, you may need to enable it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.