0

How to fix PHP Extension sockets readiness check error in magento 2.3.4.

enter image description here

1
  • please check my answer Mar 16, 2020 at 12:07

3 Answers 3

1

Open php.ini file.

Find sockets and remove the comment in the first line.

Replace

from:

;extension=sockets

To:

extension=sockets

Save the file then restart your apache server and try again.

Hope this will help you!!

0

Solution

change ;extension=sockets to extension=sockets over php.ini
0

I am experiencing the same issue. As the hosting provider is not willing to enable the extension sockets, is there a workaround to disable this extension within Magento and continue with the set-up?

Thanks for your help.

1
  • I changed the following in the file setup/src/Magento/Setup/Model/PhpReadinessCheck.php: $missing = array_values(array_diff($required, $current)); into $missing = array_values(array_diff($current, $current)); This allows to pass the php extensions check, but can anybody indicate whether this action will cause any harm? To which extent is the PHP Extension Sockets essential for running Magento?
    – gvdb
    Apr 6, 2020 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.