0

I'm facing this issue.

Exception #0 (OutOfBoundsException): No element found with ID 'reviews.tab'.

Anyone have an idea about this one?

1 exception(s):

Exception #0 (OutOfBoundsException): No element found with ID 'reviews.tab'.

Exception #0 (OutOfBoundsException): No element found with ID 'reviews.tab'.

#1 Magento\Framework\Data\Structure->getAttribute('reviews.tab', 'display') called at [vendor/magento/framework/View/Layout.php:511]
#2 Magento\Framework\View\Layout->displayElement('reviews.tab') called at [vendor/magento/framework/View/Layout.php:487]
#3 Magento\Framework\View\Layout->renderElement('reviews.tab') called at [app/code/MGS/Protabs/view/frontend/templates/product/view/details.phtml:67]
#4 include('/var/www/html/su...') called at [vendor/magento/framework/View/TemplateEngine/Php.php:59]
#5 Magento\Framework\View\TemplateEngine\Php->render(&Magento\Catalog\Block\Product\View\Description#0000000007a937c9000000005b3f1be4#, '/var/www/html/su...', array()) called at [vendor/magento/framework/View/Element/Template.php:270]
#6 Magento\Framework\View\Element\Template->fetchView('/var/www/html/su...') called at [vendor/magento/framework/View/Element/Template.php:300]
#7 Magento\Framework\View\Element\Template->_toHtml() called at [vendor/magento/framework/View/Element/AbstractBlock.php:667]
#8 Magento\Framework\View\Element\AbstractBlock->toHtml() called at [vendor/magento/framework/View/Layout.php:557]
#9 Magento\Framework\View\Layout->_renderBlock('product.info.det...') called at [vendor/magento/framework/View/Layout.php:533]
#10 Magento\Framework\View\Layout->renderNonCachedElement('product.info.det...') called at [vendor/magento/framework/View/Layout.php:488]
#11 Magento\Framework\View\Layout->renderElement('product.info.det...', true) called at [vendor/magento/framework/View/Element/AbstractBlock.php:507]
#12 Magento\Framework\View\Element\AbstractBlock->getChildHtml('product.info.det...') called at [app/design/frontend/Mgs/claue/Magento_Catalog/templates/product/view/detail_layout.phtml:150]
#13 include('/var/www/html/su...') called at [vendor/magento/framework/View/TemplateEngine/Php.php:59]
#14 Magento\Framework\View\TemplateEngine\Php->render(&Magento\Catalog\Block\Product\View\Interceptor#0000000007a937d1000000005b3f1be4#, '/var/www/html/su...', array()) called at [vendor/magento/framework/View/Element/Template.php:270]
#15 Magento\Framework\View\Element\Template->fetchView('/var/www/html/su...') called at [vendor/magento/framework/View/Element/Template.php:300]
#16 Magento\Framework\View\Element\Template->_toHtml() called at [vendor/magento/framework/View/Element/AbstractBlock.php:667]
#17 Magento\Framework\View\Element\AbstractBlock->toHtml() called at [vendor/magento/framework/View/Layout.php:557]
#18 Magento\Framework\View\Layout->_renderBlock('product.detail.i...') called at [vendor/magento/framework/View/Layout.php:533]
#19 Magento\Framework\View\Layout->renderNonCachedElement('product.detail.i...') called at [vendor/magento/framework/View/Layout.php:488]
#20 Magento\Framework\View\Layout->renderElement('product.detail.i...', false) called at [vendor/magento/framework/View/Layout.php:585]
#21 Magento\Framework\View\Layout->_renderContainer('content', false) called at [vendor/magento/framework/View/Layout.php:535]
#22 Magento\Framework\View\Layout->renderNonCachedElement('content') called at [vendor/magento/framework/View/Layout.php:488]
#23 Magento\Framework\View\Layout->renderElement('content', false) called at [vendor/magento/framework/View/Layout.php:585]
#24 Magento\Framework\View\Layout->_renderContainer('main', false) called at [vendor/magento/framework/View/Layout.php:535]
#25 Magento\Framework\View\Layout->renderNonCachedElement('main') called at [vendor/magento/framework/View/Layout.php:488]
#26 Magento\Framework\View\Layout->renderElement('main', false) called at [vendor/magento/framework/View/Layout.php:585]
#27 Magento\Framework\View\Layout->_renderContainer('columns', false) called at [vendor/magento/framework/View/Layout.php:535]
#28 Magento\Framework\View\Layout->renderNonCachedElement('columns') called at [vendor/magento/framework/View/Layout.php:488]
#29 Magento\Framework\View\Layout->renderElement('columns', false) called at [vendor/magento/framework/View/Layout.php:585]
#30 Magento\Framework\View\Layout->_renderContainer('main.content', false) called at [vendor/magento/framework/View/Layout.php:535]
#31 Magento\Framework\View\Layout->renderNonCachedElement('main.content') called at [vendor/magento/framework/View/Layout.php:488]
#32 Magento\Framework\View\Layout->renderElement('main.content', false) called at [vendor/magento/framework/View/Layout.php:585]
#33 Magento\Framework\View\Layout->_renderContainer('page.wrapper', false) called at [vendor/magento/framework/View/Layout.php:535]
#34 Magento\Framework\View\Layout->renderNonCachedElement('page.wrapper') called at [vendor/magento/framework/View/Layout.php:488]
#35 Magento\Framework\View\Layout->renderElement('page.wrapper', false) called at [vendor/magento/framework/View/Layout.php:585]
#36 Magento\Framework\View\Layout->_renderContainer('root', false) called at [vendor/magento/framework/View/Layout.php:535]
#37 Magento\Framework\View\Layout->renderNonCachedElement('root') called at [vendor/magento/framework/View/Layout.php:488]
#38 Magento\Framework\View\Layout->renderElement('root') called at [vendor/magento/framework/View/Layout.php:954]
#39 Magento\Framework\View\Layout->getOutput() called at [vendor/magento/framework/Interception/Interceptor.php:58]
#40 Magento\Framework\View\Layout\Interceptor->___callParent('getOutput', array()) called at [vendor/magento/framework/Interception/Interceptor.php:138]
#41 Magento\Framework\View\Layout\Interceptor->Magento\Framework\Interception\{closure}() called at [vendor/magento/framework/Interception/Interceptor.php:153]
#42 Magento\Framework\View\Layout\Interceptor->___callPlugins('getOutput', array(), array(array('layout-model-cac...'))) called at [generated/code/Magento/Framework/View/Layout/Interceptor.php:39]
#43 Magento\Framework\View\Layout\Interceptor->getOutput() called at [vendor/magento/framework/View/Result/Page.php:257]
#44 Magento\Framework\View\Result\Page->render(&Magento\Framework\App\Response\Http\Interceptor#0000000007a93030000000005b3f1be4#) called at [vendor/magento/framework/View/Result/Layout.php:170]
#45 Magento\Framework\View\Result\Layout->renderResult(&Magento\Framework\App\Response\Http\Interceptor#0000000007a93030000000005b3f1be4#) called at [vendor/magento/framework/Interception/Interceptor.php:58]
#46 MGS\Mpanel\Block\Framework\Page\Interceptor->___callParent('renderResult', array(&Magento\Framework\App\Response\Http\Interceptor#0000000007a93030000000005b3f1be4#)) called at [vendor/magento/framework/Interception/Interceptor.php:138]
#47 MGS\Mpanel\Block\Framework\Page\Interceptor->Magento\Framework\Interception\{closure}(&Magento\Framework\App\Response\Http\Interceptor#0000000007a93030000000005b3f1be4#) called at [vendor/magento/framework/Interception/Interceptor.php:153]
#48 MGS\Mpanel\Block\Framework\Page\Interceptor->___callPlugins('renderResult', array(&Magento\Framework\App\Response\Http\Interceptor#0000000007a93030000000005b3f1be4#), array(array('result-messages', 'result-builtin-c...', 'result-varnish-c...'))) called at [generated/code/MGS/Mpanel/Block/Framework/Page/Interceptor.php:39]
#49 MGS\Mpanel\Block\Framework\Page\Interceptor->renderResult(&Magento\Framework\App\Response\Http\Interceptor#0000000007a93030000000005b3f1be4#) called at [vendor/magento/framework/App/Http.php:140]
#50 Magento\Framework\App\Http->launch() called at [vendor/magento/framework/App/Bootstrap.php:257]
#51 Magento\Framework\App\Bootstrap->run(&Magento\Framework\App\Http\Interceptor#0000000007a93032000000005b3f1be4#) called at [index.php:39]
  • where showed this error ?? i means products page ?? – Mohit Patel Mar 13 at 16:52
  • Search all your XML files for reviews.tab - what do you find? – Ben Crook Mar 13 at 17:06
  • I see this Exception when I click on a single product. – Alain Picard Mar 13 at 17:12
  • This is my block: <block class="Magento\Review\Block\Product\Review" name="reviews.tab" template="MGS_Amp::Magento_Review/review.phtml"> – Alain Picard Mar 13 at 19:21
0

Try this may be help you

By just adding lines in below file in mymodule_index_index.xml files page node I Add layout=1column and the problem is solved.

| improve this answer | |
  • Can you clarify your point please? – Alain Picard Mar 13 at 20:52
  • Please open the your xml file for related to review tab... – Mohit Patel Mar 14 at 2:24
  • You create any custom module for review tab??? – Mohit Patel Mar 14 at 2:25
  • No, not at all. – Alain Picard Mar 14 at 5:08
  • Your create any new Or rewrite xml files for related for review tab??? – Mohit Patel Mar 14 at 5:27
0

I fix this by disabling the module loll!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.