1

I've written a new upgrade to an extension and it works just fine on my dev install.

When I package it, there are no problems.

When I try to install it from connect manager I never see the console,but the screen does scroll down to the console area.

If I refresh the connect manager my extension is listed.

All files are properly installed and the DB tables properly updated.

The Maintenance flag is not removed

After deleting the flag file, the extension functions perfectly.

this is all repeatable across multiple installation on different servers, using both CE 1.8 and 1.9.

What might be causing the flag being left and the console not working, and how can I fix it. Even after several hours consulting google, I'm at a loss. This is the only thing I know of preventing the release of this extension.

If I need to show any code, please ask for it. At this point, I don't even know what files might be causing the problem.

first request, the upgrade code from file mysql4-upgrade-0.1.3-0.1.4.php :

    <?php

$installer = $this;
//no database changes for this upgrade 

my version 0.1.3 installs just fine, my version 0.1.4 doesn't.

  • 1
    Can you place the installer or the update here? – mbalparda Jul 30 '14 at 18:02
  • added in an edit to the main question, the other installers are a bit long. Since it worked up to the previous installer I thought they're probably not needed. If you know better, please tell me and I'll add it. – Matt Flamm Jul 30 '14 at 18:13
  • How did you packed your extension? – mbalparda Jul 30 '14 at 18:28
  • Using the process in Magento, Just like outlined in "How to package Magento Extensions" on the Magento website. – Matt Flamm Jul 30 '14 at 19:22
1

Try to add this $installer->endSetup(); at the bottom of your installer script.

  • I'll try, but I never had a startSetup();. Also, 0.1.3 uses the exact same script, just with a different file name. – Matt Flamm Jul 30 '14 at 18:32
  • I don't quite understand why you have an update script if it does not do anything. – mbalparda Jul 30 '14 at 18:35
  • isn't it needed to move the version number up, so it matches the version in your xml? If i don't move the version number, connect complains when I try to upload it, and I'm not sure if it installs the updated files if there's no installer to trigger the process. Am I wrong? That's always a possibility. – Matt Flamm Jul 30 '14 at 19:19
  • Yes, you are wrong. If there is nothing to do in the installer, remove it. – mbalparda Jul 30 '14 at 19:58
  • 1
    You change the version in your extension config.xml. – mbalparda Jul 31 '14 at 7:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.