I want to install a plugin, but the readiness check gives the next error

Check Component Dependency We found conflicting component dependencies.

Command "require" failed:
In RemoteFilesystem.php line 559:

The "https://repo.magento.com/packages.json" file could not be downloaded:
SSL operation failed with code 1. OpenSSL Error messages:
error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify
Failed to enable crypto
failed to open stream: operation failed

require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [<packages>...]

I'm using Magento 2.3.3.

Has someone a solution?


What is your environnement and command used?

It seems like a SSL error with the certificate and crypto, check:

  • does it break on all call made by composer or only official magento repo?

  • is your certificate uptodate?

  • do you use any proxy or something changing your ip or dns configuration?

  • is there any firewall or antivirus blocking it?

A lot of questions 😅

  • I have a Magento webhosting Packet on versio.uk/magento-hosting. This package normally meets the requirements of Magento. This are my PHP settings: ibb.co/bzW7Z2x and I'm using a free SSL certificate from Let's Encrypt – ITcreation Mar 12 '20 at 9:47
  • I also tried with repo.packagist.org, but it gave the same error. – ITcreation Mar 12 '20 at 9:49
  • Is has to be linked with your hosting, did you check with them if they have more log about this error? you need to check the open ssl config, but maybe they restrained the connexions. Might also appears with github https repos. – Kennedy Mar 12 '20 at 10:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.