0

I recently did data migration from M1 to M2 with data migration tool. The product when opened in the edit mode from Admin would show "Use Existing" as the default value instead of "No Update" for Cusomt Layout Option under Migration_Default. The products would display only if the Custom Layout Option is No Update. I tried to set the this attribute for all the products using Update Attributes under Action dropdown, but it's not making any difference. Is there way to accomplish this? Please refer the screenshots. When a product gets saved with the custom layout update = No Update under Migration_design, the following tables would lose some records. I am not sure if there should be other table too that would also lose the entries.

  1. catalog_product_entity_datetime - All the entries got deleted.
  2. catalog_product_entity_decimal - 6 record became 3
  3. catalog_product_entity_int - 17 records became 13
  4. catalog_product_entity_text - 7 became 6
  5. catalog_product_entity_varchar - 54 became 37

enter image description here

1

In table eav_attribute, you need to find attribute_code = page_layout, entity_type_id = 4 to get the attribute_id.

After that, run this command:

delete from catalog_product_entity_varchar where attribute_id = xxx

in that, xxx = attribute_id that you've got from the above table.

  • Hi LitExtension, grateful to you for your time. I found the attribute_id which is 107. I am little nervous if deleting this record will do any irrepairable damage to the system. Please advise me what precaution do I need to take before this action. – CodeForGood Mar 12 at 9:13
  • Don't worry, there will have no damage to the system. If you are still not sure, you can back up data by running this command: create table backup_layout as select * from catalog_product_entity_varchar where attribute_id = 107 – LitExtension Magento Migration Mar 13 at 1:25
  • Thanks a lot for the assurance along with the additional information. – CodeForGood Mar 13 at 3:27
  • Hi, The error is still there. Exception #0 (Magento\Framework\Config\Dom\ValidationException): Element 'handle': Character content other than whitespace is not allowed because the content type is 'element-only' – CodeForGood Mar 16 at 8:41
  • 1
    @ LitExtension Magento Migration, your suggestions and advises have helped us find out the root cause of the problem, we will hopefully fix it shortly. – CodeForGood Mar 21 at 17:27
0

The simplest solution is to run these two SQL statements.

* DELETE * FROM eav_attribute where attribute_id = 106;
* DELETE * FROM catalog_product_entity_text table where attribute_id=106;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.