2

I started having a 500 Server Error in Magento's configuration page. The rest of the website works ok. I turned DeveloperMode on and I got the following message:

Method "addJqueryLibrary" is not defined in "Magentothem_Upsellslider_Model_Layout_Generate_Observer"

#0 /home/webiste/public_html/app/code/core/Mage/Core/Model/App.php(1340): Mage::throwException('Method "addJque...')
#1 /home/webiste/public_html/app/code/core/Mage/Core/Model/App.php(1317): Mage_Core_Model_App->_callObserverMethod(Object(Magentothem_Upsellslider_Model_Layout_Generate_Observer), 'addJqueryLibrar...', Object(Varien_Event_Observer))
#2 /home/webiste/public_html/app/Mage.php(448): Mage_Core_Model_App->dispatchEvent('controller_acti...', Array)
#3 /home/webiste/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(351): Mage::dispatchEvent('controller_acti...', Array)
#4 /home/webiste/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(269): Mage_Core_Controller_Varien_Action->generateLayoutBlocks()
#5 /home/webiste/public_html/app/code/core/Mage/Adminhtml/Controller/Action.php(275): Mage_Core_Controller_Varien_Action->loadLayout(NULL, true, true)
#6 /home/webiste/public_html/app/code/core/Mage/Adminhtml/controllers/System/ConfigController.php(95): Mage_Adminhtml_Controller_Action->loadLayout()
#7 /home/webiste/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Adminhtml_System_ConfigController->editAction()
#8 /home/webiste/public_html/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch('edit')
#9 /home/webiste/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#10 /home/webiste/public_html/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
#11 /home/webiste/public_html/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#12 /home/webiste/public_html/index.php(87): Mage::run('', 'store')
#13 {main}

Any body seen this before of know how to fix it?

1 Answer 1

3

Looks like this has been discussed on StackOverflow

Magento empty blank product page

The accepted answer reads:

It looks like the module Magentothem Upsellslider is broken. If you installed the module from somewhere else, contact the creator and tell them it isn't working. In the meantime, uninstall it by removing the file app/code/etc/modules/Magentothem_Upsellslider.xml and clear your cache.

If this is your module, you seem to be trying to call a non-existent function addJqueryLibrary in your observer. Perhaps you have a typo... should it be addJQueryLibrary?

4
  • the extension's code hasn't been updated or changed. If so, what could cause this?
    – zekia
    Commented Jul 30, 2014 at 12:59
  • Have you tried disabling the module & clearing your cache as per the article on SO?
    – Moose
    Commented Jul 30, 2014 at 13:00
  • Yes, it's the module that causes this. I'll try to re-install it or contact the creator. I just don't understand how the code could change without any action or permission... Thank you
    – zekia
    Commented Jul 30, 2014 at 13:06
  • Well, it could be as a result of conflict with another extension. Have you made any source code changes recently? The SO post mentions that the OP actually disabled another module & then the initial one worked.
    – Moose
    Commented Jul 30, 2014 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.