0

This question already has an answer here:

After migrating magento, site is full of 404 errors. Found that, if i can manually put index.php before every url - hurrey no errors

Able to login to admin with same index.php trick, and now i want to disable index.php so that all urls on site should work.

Going to system>configuration>Web>SEO>Use Web Server Rewrites = yes already. and it dosent work.

In Addition Theme setting page is also blank. tried modifying .htaceess with RewriteBase /magento to / but no luck.

[P.S. 404 are default server styled error and not custom magento error] I suspect there must be some problem with web server settings, but i'm not sure I want to fix these error, and looking for some reference or help Thank You.

marked as duplicate by Anna Völkl, Vladimir Kerkhoff, brentwpeterson, Sander Mangel, kab8609 Nov 12 '14 at 15:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

Check if you have an uncommented directive in your .htaccess like

DirectoryIndex index.php

Also the vhost should have

AllowOverride All

This is kinda old, but the vhost setup seems to be correct.

  • yes it is there DirectoryIndex index.php shud i remove it ? Vhost is correct and have Rewrite enabled AllowOverride All present – echoashu Jul 30 '14 at 9:24
  • No, its the right directive. You might be having issues with the hosting provider configuration since you have to pull some settings ad directives from your .htaccess in order to make the Magento run as expected. This is why you set AllowOvrride All in the vhost config. If its a shared hosting or something like that you will have to ask your provider for assistance. – mbalparda Jul 30 '14 at 9:25
  • Please check the DirectoryIndex does not have a # in front of it. Also check if the mod_rewrite is enabled with a2enmod rewrite and restarting apache later. – mbalparda Jul 30 '14 at 9:27
  • its a dedicated unmanaged centos , i'm the only responsible for every tweak and i do have access DirectoryIndex does not hace # but a line above it do have #default index file cant use a2enmod its centos Thanks – echoashu Jul 30 '14 at 9:31
  • Then how do you know mod_rewrite is installed and enabled? – mbalparda Jul 30 '14 at 9:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.