1

New to magento development so this might be a simple mistake, but why is this Schema missing the method magentoInfo? Do methods difference between enterprise and community?

http://www.cantonteaco.com/index.php/api/v2_soap?wsdl

EDIT:

The example client above 'Cantonteaco' is using version 1.5, which I'm guessing is the reason for the missing 'magentoInfo' method.

What other method can I use to get the version?

  • Turns out the example SOAP above is from a client of ours on a 1.5 version, is there functionality on this version that is missing? What is the best way of determining the version of a client if using 'magentoInfo' is not possible? – Eritey Jul 30 '14 at 7:30
2

I under stand your question now.

Version 1.5 does not have a call for retrieving the current version of your magento installation.

You will have to upgrade the API to a newer version or upgrade you magento version to 1.8 or above.

You can do the following.

Overwite app\code\core\Mage\Catalog\etc\api.xml and app\code\core\Mage\Catalog\etc\wsdl.xml v1.5 with v1.8 And add to v1.5 app\code\core\Mage\Catalog\Model\Product\Option\Api.php

  • 1
    What if the SOAP doesn't have either of those methods? Search the example SOAP and you won't find them. – Eritey Jul 30 '14 at 7:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.