As soon as I select "limit all", i get a server error.

All other pages are working fine. I increased my memory limit to 4 GB, checked file permissions, etc.

My error log just says Error 500.

My best guess is that it could be some kind of limited resources, cause I am working with configurable products (so for every configurable product there are 30 single products).

Edit: The error is: premature end of script. Turning of the cache works for me, however i still need to figure out how to solve it with cache turned on.

1 Answer 1


Run the follwing commands in the terminal:-

php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy

And Second Solution :-

You developer mode enable and file automatically generated requested and not found. So showing this problem

When facing a 500 error the first thing you should do is search for your webserver error log.

When running on apache it can mostly be found in one of these 2 locations:

/var/log/httpd/ -> centos, archlinux

/var/log/apache2/ -> debian, ubuntu

And No solve the your problem So Please refer this links :-


Hope help you


  • Thanks, figured it out so far. I had to overwrite /vendor/magento/module-configurable-product/Model/Plugin/ProductIdentitiesExtender.php Couldnt figure out what the right path would be to overwrite it. Do you know? app/code...?
    – user46229
    Commented Feb 25, 2020 at 20:42
  • create the module and overwrite you core files Mymodule/Overwrite/ Commented Feb 26, 2020 at 4:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.