1

I'm upgrading a theme from 2.2.x to .2.3

there are so many xml in this theme have the following directive

    <?xml version="1.0"?>
    <page xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:View/Layout/etc/page_configuration.xsd">
        <update handle="customer_account"/>
        <update handle="sales_order_item_renderers"/>
        <update handle="sales_order_item_price"/>
        <update handle="sales_order_info_links"/>
        <body>
        .........

error message display when i visit on front page:

Element 'update': This element is not expected

If update element is not supported, how can i migrate these statements to supported version?

0

Try to follow this command :-

rm -rf pub/static/frontend/ pub/static/adminhtml/ pub/static/_requirejs pub/static/deployed_version.txt var/cache var/page_cache var/generation var/view_preprocessed var/session generated/code

php bin/magento setup:upgrade

php bin/magento setup:static-content:deploy en_US -f

php bin/magento indexer:reindex

php bin/magento cache:flush

And Give Proper Permission

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.