1

I tried to do migration from Magento1.9.3.8 to Magento2.3.4, when I ran the Magento Data migration tool I always got this error:

Destination fields are not mapped. Document: paypal_settlement_report_row. Fields: store_id

I tried to fix it by modifying the map_file in etc/opensource-to-opensource/1.9.3.8/map.xml.dist, but no luck

<destination>
     ....
     <field_rules>
         ....
         <ignore>
            <datatype>paypal_settlement_report_row.store_id</datatype>
        </ignore>
    </field_rules>
</destination>
0

You can use --auto to skip this error like below.

php bin/magento migrate:data --auto vendor/magento/data-migration-tool/etc/opensource-to-opensource/1.9.3.8/config.xml

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.