2

I'm having a problem where Magmi isn't saving the selected import option when clicking Save Profile. When clicking Save Profile, the page looks like it just refreshes, and the checkmarks don't show on the next page load. Everything works fine on stage/prod, just not in my dev/local environment on my Mac. I have updated the conf and ini files to match the Mac filesystem.

I wondered if anyone else has come across this situation and if they found a possible fix.

Thanks, Mark

closed as off-topic by Raphael at Digital Pianism, Qaisar Satti, Amit Bera, Rajeev K Tomy, Anna Völkl Apr 19 '16 at 19:55

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions about third-party modules are generally off-topic because the scope of functionality and code are not available. For more information, see this meta post/answer." – Raphael at Digital Pianism, Qaisar Satti, Amit Bera, Rajeev K Tomy, Anna Völkl
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Did you find an answer here? Please mark it as solution. – Fabian Blechschmidt May 8 '13 at 14:12
  • Not really, but kind of. This error only happened on my local Mac, on prod I didn't have this problem. Since it is a local environ, 777 works just fine, so I'm inclined to believe this is the recommend solution for local Mac environments unless someone says otherwise. – Mark Shust May 23 '13 at 18:53
0

Eh.. something with permissions. Not sure exactly which files, but chmod'ing everything 777 fixes it (and is fine on local). Maybe something with mod_security or Mac ssh security...

  • Umm.. why the downvote? I answered my own question. Way to go, winner. – Mark Shust Jan 29 '13 at 14:08
  • 3
    -1 because: chmod -R 777 is like giving up. For future users it would have been nice if you had figured out which folder exactly needs write permissions – Alex Jan 29 '13 at 21:21
  • 1
    I don't think you even tried to debug the issue. Seems ALL files/folders need 777 for it to work on Mac. Not just specific folders. – Mark Shust Feb 8 '13 at 17:28
  • Why would the files need the executable bit? – Alex Feb 8 '13 at 18:30
0

Magmi needs to have 777 to conf, plugins and state to run without erros. BUT: Especially having your magmi.ini set to 777 is a big security risk, since Magmi is storing your database password in plain text in that file. If you have installed Magmi in your htdocs root, everyone can easily access it via yourdomain.com/magmi/conf/magmi.ini So setting everything to 777 is irresponsible. It's really sad that even in the Magmi wiki they recommend this without any notice.

If you need to access Magmi via web you should put a .htaccess file in your Magmi root and restrict access to either your IP if you have a static one, or set up a password protection for this directory.

  • It does not -- have everything set to 755 on a production environment and everything is working. I was referencing my LOCAL MAC environment. Not a production server.. – Mark Shust Feb 8 '13 at 17:29
0

Make sure you have correct permission to the magmi folders

  • Normal operation magmi needs following folders magmi/conf and magmi/state web-server user write and read permission

  • To install Extension or upgrade, its need the whole magmi dirs & subdirs should be writeable by the web server (Assuming you are doing the upgrade using web-UI)

  • If you are using magmi.cli.php to run profile, you don't need webserver write permission

Not the answer you're looking for? Browse other questions tagged or ask your own question.