0

Error: One or more of the Cache Types are invalidated: Configuration, Page Cache. Please go to Cache Management and refresh cache types. How can i resolve this permanently?

0

If you don't ever want to clean cache manually, there is a watcher developed by Vinai Kopp which will clean the cache automatically as it invalidates for you. Just a heads up that it is developed in node js so you'll have to install that to make it run.

You can find the documentation and source of the watcher here - https://github.com/mage2tv/magento-cache-clean

| improve this answer | |
0

Is not an issue , but a magento notice . When you make updates on admin , you need to clean cache configs. You need to Flush Magento Cache

System -> Cache Management ->  Flush Magento Cache

enter image description here

If you dont want those messages to show up in the admin :

You need to disable Magento_AdminNotification module .

Check this for more https://blog.landofcoder.com/disable-magento-2-admin-notification/

| improve this answer | |
0

Make sure whether you have nodejs

The following instructions may be helpful to you.

Global Installation: composer global require mage2tv/magento-cache-clean

PATH Setting:

  1. Open terminal run
gedit ~/.bashrc
  1. Add the following command at end of the line. (this may differ in your system)
   export PATH="$PATH:$HOME/.config/composer/vendor/bin"
  1. Save and close the file.
| improve this answer | |
0

There is no problem to solve here. Magento will flush the caches according to its own logic, as long as cron jobs are correctly configured on the server.

If you must have changes reflected on the frontend immediately, you can flush the caches manually. However, frequent cache flushing defeats the entire purpose of the cache and reduces performance for front end users.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.