1
yarn install v1.21.1 warning package-lock.json found. 

Your project contains lock files generated by tools other than Yarn. It is advised not to mix package managers in order to avoid resolution inconsistencies caused by unsynchronized lock files.

To clear this warning, remove `package-lock.json`.

- [1/5] Validating package.json...
- [2/5] Resolving packages...
- [3/5] Fetching packages...
info [email protected]: The platform "linux" is incompatible with this module.
info "[email protected]" is an optional dependency and failed compatibility check. Excluding it from installation.
- [4/5] Linking dependencies...
warning " > @magento/[email protected]" has incorrect peer dependency "eslint-plugin-react-hooks@^1.6.0".
warning " > @magento/[email protected]" has unmet peer dependency "@babel/core@~7.3.4".
warning " > @magento/[email protected]" has unmet peer dependency "@babel/plugin-proposal-class-properties@~7.3.4".
warning " > @magento/[email protected]" has unmet peer dependency "@babel/plugin-proposal-object-rest-spread@~7.3.4".
warning " > @magento/[email protected]" has unmet peer dependency "@babel/plugin-syntax-dynamic-import@~7.2.0".
warning " > @magento/[email protected]" has unmet peer dependency "@babel/plugin-syntax-jsx@~7.2.0".
warning " > @magento/[email protected]" has unmet peer dependency "@babel/plugin-transform-react-jsx@~7.3.0".
warning " > @magento/[email protected]" has unmet peer dependency "@babel/plugin-transform-runtime@~7.4.4".
warning " > @magento/[email protected]" has unmet peer dependency "@babel/preset-env@~7.3.4".
warning " > @magento/[email protected]" has unmet peer dependency "@babel/runtime@~7.4.2".
warning " > @magento/[email protected]" has unmet peer dependency "babel-plugin-dynamic-import-node@~2.2.0".
warning " > @magento/[email protected]" has unmet peer dependency "babel-plugin-graphql-tag@~2.0.0".
warning " > @magento/[email protected]" has unmet peer dependency "react-hot-loader@~4.12.17".
warning " > [email protected]" has unmet peer dependency "graphql-cli@^3".
warning " > @magento/[email protected]" has unmet peer dependency "@apollo/react-hooks@~3.1.2".
warning " > @magento/[email protected]" has unmet peer dependency "@babel/runtime@~7.4.2".
warning " > @magento/[email protected]" has unmet peer dependency "apollo-client@~2.6.4".
warning " > @magento/[email protected]" has unmet peer dependency "informed@~2.11.17".
warning " > @magento/[email protected]" has unmet peer dependency "react@~16.9.0".
warning " > @magento/[email protected]" has unmet peer dependency "react-dom@~16.9.0".
warning " > @magento/[email protected]" has unmet peer dependency "react-redux@~7.1.1".
warning " > @magento/[email protected]" has unmet peer dependency "react-router-dom@~5.1.0".
warning " > @magento/[email protected]" has unmet peer dependency "redux@~4.0.4".
warning " > @magento/[email protected]" has unmet peer dependency "redux-actions@~2.6.5".
warning " > @magento/[email protected]" has unmet peer dependency "babel-loader@~8.0.5".
warning " > @magento/[email protected]" has unmet peer dependency "css-loader@~2.1.1".
warning " > @magento/[email protected]" has unmet peer dependency "terser-webpack-plugin@~1.2.3".
warning " > @magento/[email protected]" has unmet peer dependency "webpack@~4.38.0".
warning " > @magento/[email protected]" has unmet peer dependency "workbox-webpack-plugin@~4.2.0".
warning " > @magento/[email protected]" has unmet peer dependency "express@^4.16.4".
warning " > @magento/[email protected]" has unmet peer dependency "apollo-cache-inmemory@~1.6.3".
warning " > @magento/[email protected]" has unmet peer dependency "apollo-cache-persist@~0.1.1".
warning " > @magento/[email protected]" has unmet peer dependency "[email protected]".
warning " > @magento/[email protected]" has unmet peer dependency "apollo-link-http@~1.5.11".
warning " > @magento/[email protected]" has unmet peer dependency "braintree-web-drop-in@~1.16.0".
warning " > @magento/[email protected]" has unmet peer dependency "react@~16.9.0".
warning " > @magento/[email protected]" has unmet peer dependency "react-redux@~7.1.1".
warning " > @magento/[email protected]" has unmet peer dependency "react-router-dom@~5.1.0".
warning " > @magento/[email protected]" has unmet peer dependency "redux@~4.0.1".
warning " > @magento/[email protected]" has unmet peer dependency "webpack@~4.41.2".
warning "workspace-aggregator-4d7f1716-16a5-4d05-83b9-41e41f5ec283 > @magento/pwa-buildpack > [email protected]" has unmet peer dependency "express@^4.16.2".
warning "workspace-aggregator-4d7f1716-16a5-4d05-83b9-41e41f5ec283 > @magento/venia-concept > [email protected]" has unmet peer dependency "@types/react@^15.0.0 || ^16.0.0".
warning "workspace-aggregator-4d7f1716-16a5-4d05-83b9-41e41f5ec283 > @magento/venia-ui > @apollo/[email protected]" has unmet peer dependency "@types/react@^16.8.0".
warning "workspace-aggregator-4d7f1716-16a5-4d05-83b9-41e41f5ec283 > @magento/venia-ui > @apollo/[email protected]" has unmet peer dependency "react-dom@^16.8.0".
warning "workspace-aggregator-4d7f1716-16a5-4d05-83b9-41e41f5ec283 > @magento/venia-ui > [email protected]" has unmet peer dependency "react-dom@>=16.3".
warning "workspace-aggregator-4d7f1716-16a5-4d05-83b9-41e41f5ec283 > @magento/venia-ui > [email protected]" has unmet peer dependency "react-dom@^0.14.0 || ^15.0.1 || ^16.0.0".
warning "workspace-aggregator-4d7f1716-16a5-4d05-83b9-41e41f5ec283 > @magento/venia-ui > @apollo/react-hooks > @apollo/[email protected]" has unmet peer dependency "@types/react@^16.8.0".
warning "workspace-aggregator-4d7f1716-16a5-4d05-83b9-41e41f5ec283 > @magento/venia-ui > @apollo/react-hooks > @apollo/[email protected]" has unmet peer dependency "apollo-utilities@^1.3.2".
warning "workspace-aggregator-4d7f1716-16a5-4d05-83b9-41e41f5ec283 > graphql-cli-validate-magento-pwa-queries > graphql-cli > apollo-codegen > [email protected]" has incorrect peer dependency "graphql@^0.11.0 || ^0.12.0 || ^0.13.0".
warning "workspace-aggregator-4d7f1716-16a5-4d05-83b9-41e41f5ec283 > graphql-cli-validate-magento-pwa-queries > graphql-cli > graphql-cli-prepare > [email protected]" has incorrect peer dependency "graphql@^0.11.0 || ^0.12.0 || ^0.13.0".
warning "workspace-aggregator-4d7f1716-16a5-4d05-83b9-41e41f5ec283 > graphql-cli-validate-magento-pwa-queries > graphql-cli > graphql-cli-prepare > [email protected]" has incorrect peer dependency "graphql@^0.11.0 || ^0.12.0 || ^0.13.0".
warning "workspace-aggregator-4d7f1716-16a5-4d05-83b9-41e41f5ec283 > graphql-cli-validate-magento-pwa-queries > graphql-cli > tmp-graphql-config-extension-openapi > @kbrandwijk/[email protected]" has incorrect peer dependency "graphql@^0.12.0 || ^0.13.0".

- [5/5] Building fresh packages...
- [8/12] ⠂ iltorb
- [-/12] ⠂ waiting...
- [3/12] ⠂ iltorb
- [4/12] ⠄ sharp
error /home/aspire1030/pwa-studio/node_modules/sharp: Command failed.
Exit code: 1
Command: (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)
Arguments: 
Directory: /home/aspire1030/pwa-studio/node_modules/sharp
Output:
info sharp Downloading https://github.com/lovell/sharp-libvips/releases/download/v8.8.1/libvips-8.8.1-linux-x64.tar.gz
ERR! sharp tunneling socket could not be established, statusCode=503
info sharp Attempting to build from source via node-gyp but this may fail due to the above error
info sharp Please see https://sharp.pixelplumbing.com/page/install for required dependencies
gyp info it worked if it ends with ok
gyp info using [email protected]
gyp info using [email protected] | linux | x64
gyp info spawn /usr/bin/python2
gyp info spawn args [ '/home/aspire1030/pwa-studio/packages/venia-concept/node_modules/node-gyp/gyp/gyp_main.py',
gyp info spawn args   'binding.gyp',
gyp info spawn args   '-f',
gyp info spawn args   'make',
gyp info spawn args   '-I',
gyp info spawn args   '/home/aspire1030/pwa-studio/node_modules/sharp/build/config.gypi',
gyp info spawn args   '-I',
gyp info spawn args   '/home/aspire1030/pwa-studio/packages/venia-concept/node_modules/node-gyp/addon.gypi',
gyp info spawn args   '-I',
gyp info spawn args   '/home/aspire1030/.node-gyp/10.16.3/include/node/common.gypi',
gyp info spawn args   '-Dlibrary=shared_library',
gyp info spawn args   '-Dvisibility=default',
gyp info spawn args   '-Dnode_root_dir=/home/aspire1030/.node-gyp/10.16.3',
gyp info spawn args   '-Dnode_gyp_dir=/home/aspire1030/pwa-studio/packages/venia-concept/node_modules/node-gyp',
gyp info spawn args   '-Dnode_lib_file=/home/aspire1030/.node-gyp/10.16.3/<(target_arch)/node.lib',
gyp info spawn args   '-Dmodule_root_dir=/home/aspire1030/pwa-studio/node_modules/sharp',
gyp info spawn args   '-Dnode_engine=v8',
gyp info spawn args   '--depth=.',
gyp info spawn args   '--no-parallel',
gyp info spawn args   '--generator-output',
gyp info spawn args   'build',
gyp info spawn args   '-Goutput_dir=.' ]
make: Entering directory '/home/aspire1030/pwa-studio/node_modules/sharp/build'
gyp info spawn make
gyp info spawn args [ 'BUILDTYPE=Release', '-C', 'build' ]
  TOUCH Release/obj.target/libvips-cpp.stamp
  CXX(target) Release/obj.target/sharp/src/common.o
../src/common.cc:25:22: fatal error: vips/vips8: No such file or directory
compilation terminated.
sharp.target.mk:127: recipe for target 'Release/obj.target/sharp/src/common.o' failed
make: Leaving directory '/home/aspire1030/pwa-studio/node_modules/sharp/build'
make: *** [Release/obj.target/sharp/src/common.o] Error 1
gyp ERR! build error 
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/home/aspire1030/pwa-studio/packages/venia-concept/node_modules/node-gyp/lib/build.js:262:23)
gyp ERR! stack     at ChildProcess.emit (events.js:198:13)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:248:12)
gyp ERR! System Linux 4.15.0-76-generic
gyp ERR! command "/usr/bin/node" "/home/aspire1030/pwa-studio/node_modules/.bin/node-gyp" "rebuild"
gyp ERR! cwd /home/aspire1030/pwa-studio/node_modules/sharp
1
  • 3
    I'm voting to close this question as off-topic because it is not related to Magento
    – Piyush
    Feb 12, 2020 at 11:23

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.