0

below error facing when i try to reindex :

{"error":{"root_cause":[{"type":"illegal_argument_exception","reason":"In Shingle TokenFilter the difference between max_shingle_size and min_shingle_size (and +1 if outputting unigrams) must be less than or equal to: [3] but was [9]. This limit can be set by changing the [index.max_shingle_diff] index level setting."}],"type":"illegal_argument_exception","reason":"In Shingle TokenFilter the difference between max_shingle_size and min_shingle_size (and +1 if outputting unigrams) must be less than or equal to: [3] but was [9]. This limit can be set by changing the [index.max_shingle_diff] index level setting."},"status":400}

OS : ubuntu Magento 2.3.4

enter image description here enter image description here

0

I think the problem is with the ElasticSearch version itself which is installed on the Ubuntu OS on your system.

The reason is that Magento 2.3.4 is not compatible with ElasticSearch 7.x versions.

You should try with the Elastic Search 6.x(6.8.6) version.

ElasticSearch version should be the 6.x.x, wherein the above screenshot it says 7.5.2.

"version" : {
    "number" : "7.5.2",
    ..
    ..
    ..     
 }

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.