0

Looking to have this as a bit of a potential timesave for developers trying to upgrade their Magento 2.3.2 store to 2.3.3

We can maintain this as a community and hopefully ease the pain on others once we've gone through the fire ourselves.

Known Upgrade Issues

One thing that caused me pain was that the third party payment modules broke because in Magento 2.3.2 in the default Magento_Checkout/js/view/payment/default::placeOrder method, the isPlaceOrderActionAllowed value wasn't getting checked, but in Magento 2.3.3 the placeOrder method only runs when that observable is set to true.

That's a great design choice, to make sure the place order action IS ALLOWED, but it does cause issues with modules that didn't have that properly set in 2.3.2 and got away with it. Just something to be aware of...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.