0

Any idea why I can't disable backups in Magento 2.3.3?

I've tried through the admin panel and when I change the enabled setting from "yes" to "no" and save the page, it still shows "yes" when the page refreshes. I tried disabling the automatic backups first and then disabling backups entirely, but when I save the settings and the page refreshes, both still show "yes".

enter image description here

I tried through the command line using:

bin/magento config:set system/backup/functionality_enabled 0

and get: value saved in response, but when I go back to the control panel in Magento and check, it shows that backups are still enabled.

I tried clearing the caches, then tried blowing away the caches. I also tried a complete reindexing and there was no difference.

As far as I can tell any/all other settings in the Magento panel are behaving as expected, so it seems that the problem is isolated to backup settings...

Anyone seen this before, or have an idea what to look at to get these backup jobs shut off?

  • check the cache, that maybe your problem – Sohel Rana Jan 30 at 17:49
  • @SohelRana - Thanks. I cleared and then blew away the caches. I also reindexed everything. No different. I will update the original question. – Greg Nickoloff Jan 30 at 18:41
0

It looks like the backups via the Magento back-end are actually disabled. Here's what we see when checking the database:

+-----------+---------+----------+------------------------------------+----------+
| config_id | scope | scope_id | path | value |
+-----------+---------+----------+------------------------------------+----------+
| 99 | default | 0 | system/backup/functionality_enabled| 0 |
| 100 | default | 0 | system/backup/enabled | 0 |

so this must be an admin. interface problem of some kind.

Blowing away the caches and reindexing several times eventually caught things up with the database.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.