2

I have Magento 2.3 installation on Nginx server. I removed .html suffix from configuration by going to

System > Config > Catalog -> Catalog -> Search Engine Optimization

enter image description here

Now the categories and products are opening on frontend without html but homepage shows 404 page not found

I tried clearing all the cache, reindexed all the indexes, deployed static content with no luck.

Do I have to change any Nginx setting to make it work?

1

Referring to question - Magento 2 - Homepage is 404

See if there are any records missing value for request path using below query:

SELECT * FROM `url_rewrite` WHERE request_path='';

Either remove those records or update with valid values.

| improve this answer | |
  • That worked! thanks @rizwan – Nausif Feb 4 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.