0

one of our contact forms is not sending (or at least the email is not arriving). I googled this out, but to no avail.

We have the following set-up.

  • 1 installation, 2 domains
  • 1 domain setup as alias and using htaccess to set store flag
  • 1 contact form CMS page used for both stores
  • store 1 is sending from noreply@store1.com to info@store1.com, set in contacts under config
  • store 2 is sending from noreply@store2.com to info@store2.com, set in contacts under config

Store 1 emails are arriving. Store 2 emails not.

  • We changed the Store 2 recipient email to a gmail. And this works!!!

And to make it even more complex

  • The order confirmation emails are being sent (to info@)
0

It sounds to me like the server sending the emails outbound to @store2.com email addresses has a mail server running on it, capturing outbound emails destined for inboxes it believes it should be handling locally. If mail is not handled by the same server as that which hosts the site, try disabling local mail delivery. Otherwise, it could be spam filters as @philwinkle mentioned.

0

Because your email delivers when sent to Gmail, it sounds like the email is being trapped on your server as spam. Try not setting the email address as the 'redirect' domain, but rather to send as the actual email domain. Try setting up the free Aschroder_SmtpPro extension and point the email to an external SMTP server. That extension is available here:

http://www.magentocommerce.com/magento-connect/aschroder-com-smtp-pro-email-free-and-easy-magento-emailing-for-smtp-gmail-or-google-apps-email.html

Overall, to increase email deliverability you should implement DKIM/SPF. This is a great blog post on how to do this (if you host your own DNS):

http://www.digitalsanctuary.com/tech-blog/debian/setting-up-spf-senderid-domain-keys-and-dkim.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.