0

I did google how to do it, I found one solution online https://www.metagento.com/blog/magento-2-disable-newsletter-subscription-success-email

https://github.com/metagento/magento-2-disable-newsletter-success-email

however I don't know why I can't install, I did check the module status, it not showing in the list. even I follow from their website, still no success.

php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy
php bin/magento cache:flush

can anyone tell me how to get this thing install?

thanks

1

Since you are using dependency injection that is di.xml You need to compile you di

Try running the below command

php bin/magento setup:di:compile
0

Did composer throw any errors when you ran composer require metagento/disable-newsletter-success-magento2?

Make sure to run composer update after running that composer require command above, then try running the other commands:

  • php bin/magento setup:upgrade
  • php bin/magento setup:static-content:deploy
  • php bin/magento cache:flush
0

If you can't see installed module by module:status you can check in config.php file.

Still, you are not able to install module then there is an issue in the module.

There is one another module I have searched for disabling newsletter email Disable newsletter mail install and check.

Note: I have not tested this extension.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.