0

I want to redirect some old URL's to new URL's I'm doing it in my .htaccess path: /root/.htaccess

<IfModule mod_rewrite.c>

############################################
## Enable rewrites

    Options +FollowSymLinks
    RewriteEngine on

    Redirect 301 https://www.example.com/store/bra_bust_lift.html https://www.example.com/intimates/womens-intimates/bra-converters.html

after that when I hit old URL it redirect me to 404 Page, it should redirect me to new URL.

0

Check and enable Web Server Rewrites

To enable URL rewrites

  • Stores>Configuration> Web
  • Expand the Search Engine Optimization section
  • Set Use Web Server Rewrites to “Yes.”
  • When complete, tap Save Config

Follow this link for more info https://www.magestore.com/magento-2-tutorial/magento-2-how-to-configure-url-rewrites/ .

Try to update your rule into this .

Redirect 301 /store/bra_bust_lift.html /intimates/womens-intimates/bra-converters.html

Check if you apache needs a restart . Do a flush cache storage.

Check if you use nginx instead of apache .

|improve this answer|||||
  • Web Server Rewrites was enabled, actually the problem was with my server I'm using nginix I had to add urls to it. – Partab Saifuddin Zakir Jan 22 at 15:19
  • 1
    Glad you fixed it – Ylgen Guxholli Jan 22 at 15:22
  • Please update your answer so I can approve it... – Partab Saifuddin Zakir Jan 22 at 15:24
  • Updated @PartabSaifuddinZakir . Thank you – Ylgen Guxholli Jan 22 at 15:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.