1

Am using magento 1.8.1 version and i have updated Manufacturers for about 400 products via CSV file. The manufacturers value is assigned correctly to their respective products.

But its not showing on the Frontend of the website. Here's a twist. When i OPEN and EDIT the product From admin and SAVE it, and then it shows up on the website in both layered navigation and in additional specs.

I cannot find the source of my problem. Can anyone guide me to solve this ?

Thanks.

2
  • Did you refresh the indexes via System -> Index management?
    – Kenny
    Jul 25, 2014 at 9:46
  • @KennyDs:: Yes i have done it.
    – Franc
    Jul 25, 2014 at 9:55

1 Answer 1

0

Please make sure you've cleared all the product related indexes and then you'll need to also clear a number of caches. If you have a low traffic site I'd advise you to just clear the entire 'Cache Storage'.

If you're a high traffic website you'll want to try clearing Blocks HTML output and Collections Data.

If that still didn't work you'll need to verify that the manufacturer attribute has Visible on Product View Page on Front-end set to yes.

You can do this through Catalog > Attributes > Manage Attributes and locating the manufacturer and making the change. You'll need to clear the caches if this was previously disabled.

6
  • Am doing this in my local environment. I have cleared cache and then done the total reindexing. I have not customized my template. And the front-end is set to YES.
    – Franc
    Jul 25, 2014 at 11:22
  • @Franc which template are you using?
    – Dave
    Jul 25, 2014 at 11:27
  • Its default one.
    – Franc
    Jul 25, 2014 at 13:11
  • Do you import the data from the CSV trough Magento's build in import/export module or have you written your own code ? - By MaxiAxi.com Jul 25, 2014 at 14:27
  • @FabianBlechschmidt I have used the admin panel to import the csv file. NO custom codes. My core files are untouched. The import was successful.
    – Franc
    Jul 26, 2014 at 9:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.