0

I'm upgrading from Magento 1.8.1 to Magento 2.3.3. So far, I have the data migration tools installed and the proper config.xml set with all proper configurations. I haven't touched the map.xml file, because I don't believe there are any custom mappings required in my case.

The settings migration seems to run fine and complete. However, when I run the data migration command I get the following warning and the process halts:

catalog_product_entity not found

Below is exactly what the screenprints in text form. HOWEVER, I have triple checked and that table fully exists. I can see it in PHPMyAdmin and all the data therein. I did notice that the warning message doesn't have the table prefix specified. I, again, have triple checked this as well. I have completely specified the source and destination prefixes in the config.xml file. The source is "mage_" and the destination is "ma233". Bear in mind, it stops at integrity check step one at 58%. If it wasn't picking the prefixes up correctly, I would think it would have failed immediately on the settings migration.

Can someone please help, it would greatly be appreciated!!!

[2020-01-17 01:03:19][INFO][mode: data][stage: integrity check][step: Data Integrity Step]: started
58% [================>-----------] Remaining Time: < 1 sec
In Mysql.php line 110:

  SQLSTATE[42S02]: Base table or view not found: 1146 Table 'stagingddbunlimi_store_storemagento.catalog_product_entity' doesn't exist, query was: SELECT DISTINCT  `child`.`prod_id` FROM `mage_files` AS `child`
   LEFT JOIN `catalog_product_entity` AS `parent` ON child.prod_id = parent.entity_id WHERE (child.prod_id IS NOT NULL) AND (parent.entity_id IS NULL)


In Mysql.php line 91:

  SQLSTATE[42S02]: Base table or view not found: 1146 Table 'stagingddbunlimi_store_storemagento.catalog_product_entity' doesn't exist
 SQLSTATE[42S02]: Base table or view not found: 1146 Table 
2
  • please check with this - magento.stackexchange.com/questions/288082/… Jan 17 '20 at 5:01
  • Thanks for you comment, and Yes, I specified that in my original post. I had the source and destination prefix both specified in the config.xml. I checked the database multiple times to ensure they both were correct, along with checking the local.xml file in the 1.8.1 install. I just can't find where there would be an issue.
    – rmc
    Jan 17 '20 at 17:41
1

I finally solved the issue. Within phpmyadmin, I created a copy of the source database, and then removed the table prefixes from all tables. I then changed the config.xml file to reflect the new copied source database, which now have the prefixes removed. After running the data migration command, it appears to have migrated the data successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.