1

I have a question about filterSearch. While I type '27000000002'. It doesn't work properly. (See below picture) o

This is my setting on the .xml file.

  <dataSource name="acer_pushorderstatus_grid_data_source" component="Magento_Ui/js/grid/provider">
    <argument name="dataProvider" xsi:type="configurableObject">
        <!--class is for php-->
        <argument name="class" xsi:type="string">Magento\Framework\View\Element\UiComponent\DataProvider\DataProvider</argument>
        <argument name="name" xsi:type="string">acer_pushorderstatus_grid_data_source</argument>
        <argument name="primaryFieldName" xsi:type="string">id</argument>
        <argument name="requestFieldName" xsi:type="string">id</argument>
        <argument name="data" xsi:type="array">
            <item name="config" xsi:type="array">
                <item name="update_url" xsi:type="url" path="mui/index/render"/>
                <item name="component" xsi:type="string">Magento_Ui/js/grid/provider</item>
            </item>
            <item name="storageConfig" xsi:type="array">
                <item name="indexField" xsi:type="string">order_number</item>
            </item>
        </argument>
    </argument>
</dataSource>

And filterSearch code is below

<listingToolbar name="listing_top">
    <bookmark name="bookmarks"/>
    <columnsControls name="columns_controls"/>
    <exportButton name="export_button"/>
    **<filterSearch name="fulltext"/>**
    <filters name="listing_filters"/>
    <paging name="listing_paging"/>
</listingToolbar>

Is anyone knows how to solve this problem?

1

After checking my databases, I realize I have to add "INDEX_TYPE_FULLTEXT" to UpgradeSchema.php (See below picture)

enter image description here

Then search bar works.

Happy coding.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.