0

I've recently moved a Magento 2 site to a new server. I'm facing a strange problem. Whenever I hit the URL in any browser, it downloads a system file instead of taking me to the site. It doesn't generate any error log. I've tried with different browsers but the problem persists.

I removed all the cache files and still doesn't work. I've never had this issue. Any idea what might cause this error?

Thanks for the help in advance!

3
  • Please check permission. Jan 13 '20 at 2:00
  • I have. I changed folder permission to 755 but still doesn't work. @AnasMansuri Jan 13 '20 at 2:08
  • let me know which error are you facing? Jan 13 '20 at 4:41
0

Make sure Apache server rewrites are enabled.

0

php is not enabled or handler not set properly. this is why you download php as text. you need to execute php.

if you run cPanel then go to profile customization and install php-fpm or mod_php.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.